1003 Emergency (25分)

1003 Emergency (25分)
As an emergency rescue team leader of a city, you are given a special map of your country. The map shows several scattered cities connected by some roads. Amount of rescue teams in each city and the length of each road between any pair of cities are marked on the map. When there is an emergency call to you from some other city, your job is to lead your men to the place as quickly as possible, and at the mean time, call up as many hands on the way as possible.

Input Specification:
Each input file contains one test case. For each test case, the first line contains 4 positive integers: N (≤500) - the number of cities (and the cities are numbered from 0 to N−1), M - the number of roads, C1 and C​2 - the cities that you are currently in and that you must save, respectively. The next line contains N integers, where the i-th integer is the number of rescue teams in the i-th city. Then M lines follow, each describes a road with three integers c1, c2 and L, which are the pair of cities connected by a road and the length of that road, respectively. It is guaranteed that there exists at least one path from C​1 to C2 .

Output Specification:
For each test case, print in one line two numbers: the number of different shortest paths between C​1 and C2 , and the maximum amount of rescue teams you can possibly gather. All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:

5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1

Sample Output:

2 4

PS:dijksta模板(熟记),加上两个数组num和w同时进行处理就可以得出答案(需要注意是无向图)。

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
const int maxn = 1000;
const int inf = 0x3fffffff;
int weight[maxn];
int map[maxn][maxn];
bool vis[maxn] = { false };
int dis[maxn],w[maxn],num[maxn];
int n, m, C1, C2;
int c1, c2, L;
void dijkstra(int s)
{
	fill(dis, dis + maxn, inf);
	memset(w, 0, sizeof(w));
	memset(num, 0, sizeof(num));
	num[s] = 1;
	w[s] = weight[s];
	dis[s] = 0;
	for (int i = 0; i < n; i++)
	{
		int u=-1, min=inf;
		for (int j = 0; j < n; j++)
		{
			if (vis[j] == false && dis[j] < min)
			{
				u = j;
				min = dis[j];
			}
		}
		if (u == -1) break;
		vis[u] = true;
		for (int v = 0; v < n; v++)
		{
			if (map[u][v] != inf && vis[v] == false)
			{
				if (dis[u] + map[u][v] < dis[v])
				{
					dis[v] = dis[u] + map[u][v];
					w[v] = weight[v] + w[u];
					num[v] = num[u];
				}
				else if (dis[u] + map[u][v] == dis[v])
				{
					if (w[v] < weight[v] + w[u])
					{
						w[v] = weight[v] + w[u];
					}
					num[v] += num[u]; 
				}
			}
		}
	}
}
int main(void)
{
	cin >> n >> m >> C1 >> C2;
	for (int i = 0; i < n; i++)
	{
		cin >> weight[i];
	}
	fill(map[0], map[0] + maxn * maxn, inf);
	for (int i = 0; i < m; i++)
	{
		cin >> c1 >> c2 >> L;
		map[c1][c2] = map[c2][c1] = L;
	}
	dijkstra(C1);
	printf("%d %d\n", num[C2],w[C2]);
	return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值