FatMouse and JavaBean II zoj2526

Description
So this is the second version of FatMouse and his favorite food, JavaBean – boy he just cannot have enough of it, can he? Again FatMouse was lucky enough to find a map of another storehouse which contains JavaBean. The map showed several scattered rooms storing JavaBeans and the rooms were connected by some tunnels. Amount of JavaBeans in each room and the length of each tunnel between any pair of rooms were marked on the map. After some negotiations FatMouse finally had a cat agree to clear two of the rooms’ guards for him to enter and leave, under the condition that he had to leave as soon as possible from the other end. Now he comes to you with his map, asking if you could tell him the path for getting the maximum amount of JavaBeans.
Input:

Input consists of several test cases.
For each test case, the first line contains 4 positive integers: N (<= 500) - the number of rooms (and the rooms are numbered from 0 to N-1), M - the number of tunnels, Rm1 and Rm2 - the rooms that FatMouse may enter or leave. The next line contains N integers, where the i-th integer is the number of JavaBeans at the i-th room. Then M lines follow, each describes a tunnel with three integers R1, R2 and L, which are the pair of rooms connected by a tunnel and the length of that tunnel, respectively.
It is guaranteed that there exists at least one path from Rm1 to Rm2.

Output:

For each test case, print in the first line two numbers: the number of different paths that satisfy his agreetment with the cat, and the maximum amount of JavaBeans FatMouse can possibly take. Then in the second line, print the rooms on the path which bring him the maximum profit, from Rm1 to Rm2. It is guaranteed that this path is unique since I am too lazy to write up a special judge program :)
All the numbers in a line must be separated by exactly one space, and there is no extra space allowed at the end of a line.

Sample Input:
5 6 0 2
1 2 1 5 3
0 1 1
0 2 2
0 3 1
1 2 1
2 4 1
3 4 1
1 0 0 0
2
Sample Output:
2 4
0 1 2
1 2
0

(1)题意:给一个起点,终点。再给一些图中点的关系路。从起点到终点的最短路径有多少条。如果路径相同,求使得bean最多的一条,输出bean的数量,并输出路径。
(2)解法:用Dijkstra记录最短路径。如果路径相同,有bean多时更新状态。都记录下路径与数量。

#include<cstdio>
#include<cmath>
#include<cstring>
#include<algorithm>
#include<iostream>
using namespace std;
#define INF 10000100

int map[505][505];
int d[505];
bool visit[505];
int sb[505];
int n,m,RM1,RM2;
int bean[505];
int path[505];
int number[505];
int out[505];


void Dijkstra(int s)
{
    fill(d,d+n,INF);
    fill(visit,visit+n,false);
   // fill(sb,sb+n,0);
   memset(sb,0,sizeof(sb));

    for(int i=0;i<n;i++)
    {
        d[i]=map[s][i];
        sb[i]=bean[s]+bean[i];
        path[i]=s;
        number[i]=1;
    }

    visit[s]=true;
   // sb[s]=sb[s]-bean[s];
    d[s]=0;
    sb[s]=bean[s];
    while(true)
    {
        int v=-1;
        for(int u=0;u<n;u++)
        {
            if(!visit[u]&&(v==-1||d[u]<d[v])) v=u;
        }
        if(v==-1) break;
        visit[v]=true;
        for(int u=0;u<n;u++)
        {
            if(visit[u]==true) continue;
            if(d[u]>d[v]+map[v][u])
            {
                d[u]=d[v]+map[v][u];
                sb[u]=sb[v]+bean[u];
                path[u]=v;
                number[u]=number[v];
            }
            else if (d[u]==d[v]+map[v][u])
            {
                number[u]=number[u]+number[v];

                if(sb[u]<sb[v]+bean[u])
                {
                    sb[u]=sb[v]+bean[u];
                    path[u]=v;
                }
            }
        }
    }
}
int main()
{
    while(scanf("%d %d %d %d",&n,&m,&RM1,&RM2)!=EOF)
    {
        int i,j;
        for(i=0;i<n;i++) scanf("%d",&bean[i]);

        for(i=0;i<n;i++)
        for(j=0;j<n;j++)
        {
            if(i==j) map[i][j]=0;
            else  map[i][j]=INF;
        }

        int a,b,c;
        for(i=0;i<m;i++)
        {
            scanf("%d %d %d",&a,&b,&c);
            map[a][b]=map[b][a]=c;
        }

        Dijkstra(RM1);

       /* for(i=0;i<n;i++) printf("%d ",d[i]);
        printf("\n");
        for(i=0;i<n;i++) printf("%d ",sb[i]);
        printf("\n");*/

        printf("%d %d\n",number[RM2],sb[RM2]);
        int z=0;
        while(RM1!=RM2)
        {
            out[z]=RM2;
            z++;
            RM2=path[RM2];
        }
        out[z]=RM2;
        for(i=z;i>0;i--)
        {
            printf("%d ",out[i]);
        }
        printf("%d\n",out[0]);
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值