hdu1162 Eddy's picture 并查集+最小生成树

Problem Description
Eddy begins to like painting pictures recently ,he is sure of himself to become a painter.Every day Eddy draws pictures in his small room, and he usually puts out his newest pictures to let his friends appreciate. but the result it can be imagined, the friends are not interested in his picture.Eddy feels very puzzled,in order to change all friends ‘s view to his technical of painting pictures ,so Eddy creates a problem for the his friends of you.
Problem descriptions as follows: Given you some coordinates pionts on a drawing paper, every point links with the ink with the straight line, causes all points finally to link in the same place. How many distants does your duty discover the shortest length which the ink draws?

Input
The first line contains 0 < n <= 100, the number of point. For each point, a line follows; each following line contains two real numbers indicating the (x,y) coordinates of the point.

Input contains multiple test cases. Process to the end of file.

Output
Your program prints a single real number to two decimal places: the minimum total length of ink lines that can connect all the points.

Sample Input
3
1.0 1.0
2.0 2.0
2.0 4.0

Sample Output
3.41

Author
eddy

题意:把所有点连起来。。使得总长最小。。
并查集+最小生成树。。。

#include<cstdio>
#include<cmath>
#include<cstring>
#include<iostream>
#include<algorithm>
#include<queue>
#include<vector>
#include<map>
#include<stack>
#pragma comment(linker,"/STACK:102400000,102400000")
#define pi acos(-1.0)
#define EPS 1e-6
#define INF (1<<24)
using namespace std;
struct EDGE{
    int x,y;
    double dis;
}edge[10005];
struct POINT{
    double x,y;
}point[105];
int father[105];
int pp;
int n;

bool cmp(struct EDGE a,struct EDGE b)
{
    return a.dis-b.dis<EPS;
}
int findfather(int x)
{
    if(x!=father[x])
        father[x]=findfather(father[x]);
    return father[x];
}
void Uion(int x,int y)
{
    int a=findfather(x);
    int b=findfather(y);
    father[a]=b;
}
bool same(int x,int y)
{
    if(findfather(x)==findfather(y)) return true;
    else return false;
}
double kruskal()
{
    int i;
    for(i=0;i<=n;i++) father[i]=i;
    double res=0;
    for(i=0;i<pp;i++)
    {
        if(same(edge[i].x,edge[i].y)==false)
        {
            Uion(edge[i].x,edge[i].y);
            res+=edge[i].dis;
        }
    }
    return res;
}
int main()
{
    while(scanf("%d",&n)!=EOF)
    {
        int i,j;
        for(i=0;i<n;i++) scanf("%lf %lf",&point[i].x,&point[i].y);
        pp=0;
        for(i=0;i<n;i++)
        {
            for(j=i+1;j<n;j++)
            {
                edge[pp].x=i;
                edge[pp].y=j;
                double oo=(point[i].x-point[j].x)*(point[i].x-point[j].x);
                oo=oo+(point[i].y-point[j].y)*(point[i].y-point[j].y);
                edge[pp].dis=sqrt(oo);
                pp++;
            }
        }
        sort(edge,edge+pp,cmp);
        double out=kruskal();
        printf("%.2f\n",out);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值