hdu5761Rower Bo+数学积分

Problem Description
There is a river on the Cartesian coordinate system,the river is flowing along the x-axis direction.

Rower Bo is placed at (0,a) at first.He wants to get to origin (0,0) by boat.Boat speed relative to water is v1,and the speed of the water flow is v2.He will adjust the direction of v1 to origin all the time.

Your task is to calculate how much time he will use to get to origin.Your answer should be rounded to four decimal places.

If he can’t arrive origin anyway,print”Infinity”(without quotation marks).

Input
There are several test cases. (no more than 1000)

For each test case,there is only one line containing three integers a,v1,v2.

0≤a≤100, 0≤v1,v2,≤100, a,v1,v2 are integers

Output
For each test case,print a string or a real number.

If the absolute error between your answer and the standard answer is no more than 10−4, your solution will be accepted.

Sample Input

2 3 3
2 4 3

Sample Output

Infinity
1.1428571429

Source
2016 Multi-University Training Contest 3

dt/dr=v2cosθv1 ​​

dx/dt=v2v1cosθ

上下界都是清晰的,定积分一下:

相对于Y轴方向: 0a=v2T0cosθdtv1T
相对于x轴方向: 00=v2Tv1T0cosθdt

直接把第一个式子代到第二个里面

v2T=v1v2(a+v1T)v2T

T=v1av12v22

#include<cstdio>
#include<cstring>
#include<cmath>
#include<map>
using namespace std;
#define LL long long

int main(){
    int a,v1,v2;
    while(scanf("%d %d %d",&a,&v1,&v2)!=EOF){
        if(a==0) printf("0.0000000000\n");
        else if(v1<=v2) printf("Infinity\n");
        else{
            printf("%.10f\n",1.0*a*v1/(v1*v1-v2*v2));
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值