hdu5753Permutation Bo+数学期望

Problem Description
There are two sequences h1∼hn and c1∼cn. h1∼hn is a permutation of 1∼n. particularly, h0=hn+1=0.

We define the expression [condition] is 1 when condition is True,is 0 when condition is False.

Define the function f(h)=∑ni=1ci[hi>hi−1 and hi>hi+1]

Bo have gotten the value of c1∼cn, and he wants to know the expected value of f(h).

Input
This problem has multi test cases(no more than 12).

For each test case, the first line contains a non-negative integer n(1≤n≤1000), second line contains n non-negative integer ci(0≤ci≤1000).

Output
For each test cases print a decimal - the expectation of f(h).

If the absolute error between your answer and the standard answer is no more than 10−4, your solution will be accepted.

Sample Input

4
3 2 4 5
5
3 5 99 32 12

Sample Output

6.000000
52.833333

Source
2016 Multi-University Training Contest 3

1 2 3

1 2 3 用到了第3位
1 3 2 用到了第2位
2 1 3 用到了第1,3位
2 3 1 用到了第2位
3 1 2 用到了第1,3位
3 2 1 用到了第1位

总共有6种,第一位出现的3次,第二位出现了2次,第三位出现了3次。。
找个大点的排列直接打个表,观察每一位出现的频率,可观察得到第一位和最后一位出现频率为0.5,其他都是1/3;

#include<cstdio>
#include<cstring>
#include<cmath>
using namespace std;
#define LL long long

int main(){
    int n;
    int a[1005];
    while(scanf("%d",&n)!=EOF){
        for(int i=1;i<=n;i++) scanf("%d",&a[i]);
        if(n==1){
            printf("%d\n",a[1]);
        }
        else{
            double ans=0;
            ans+=a[1]*0.5;
            ans+=a[n]*0.5;
            for(int i=2;i<n;i++) ans+=a[i]*(1.0/3);
            printf("%f\n",ans);
        }
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值