hdu5536Chip Factory+字典树

Problem Description
John is a manager of a CPU chip factory, the factory produces lots of chips everyday. To manage large amounts of products, every processor has a serial number. More specifically, the factory produces n chips today, the i-th chip produced this day has a serial number si.

At the end of the day, he packages all the chips produced this day, and send it to wholesalers. More specially, he writes a checksum number on the package, this checksum is defined as below:
maxi,j,k(si+sj)⊕sk

which i,j,k are three different integers between 1 and n. And ⊕ is symbol of bitwise XOR.

Can you help John calculate the checksum number of today?

Input
The first line of input contains an integer T indicating the total number of test cases.

The first line of each test case is an integer n, indicating the number of chips produced today. The next line has n integers s1,s2,..,sn, separated with single space, indicating serial number of each chip.

1≤T≤1000
3≤n≤1000
0≤si≤109
There are at most 10 testcases with n>100

Output
For each test case, please output an integer indicating the checksum number in a line.

Sample Input

2
3
1 2 3
3
100 200 300

Sample Output

6
400

Source
2015ACM/ICPC亚洲区长春站-重现赛(感谢东北师大)
不同的i,j,k使得 (si,+sj)sk 最大
将所有的数插入字典树中,枚举i,j从字典树中删去,然后找与 si+sj 亦或最大的,贪心就好。

#include<bits/stdc++.h>
using namespace std;
#define LL long long

const int maxnode=1000000;
const int sigma_size=2;
struct Tire{
    int ch[maxnode][sigma_size];
    int val[maxnode];
    int sz=1;
    void init(){
        sz=1;
        memset(ch,0,sizeof(ch));
        memset(val,0,sizeof(val));
    }
    void T_insert(int x,int p){
        int u=0;
        for(int i=31;i>=0;i--){
            int c=(x>>i)&1;
            if(!ch[u][c]){
                memset(ch[sz],0,sizeof(sz));
                val[sz]=0;
                ch[u][c]=sz++;
            }
            u=ch[u][c];
            val[u]+=p;
        }
    }
    LL query(int x){
        int u=0;
        LL ans=0;
        for(int i=31;i>=0;i--){
            ans*=2;
            int c=(x>>i)&1;
            //如果左右两边都存在一定是选择与它相反的分支,
            if(ch[u][c^1]&&val[ch[u][c^1]]){
               u=ch[u][c^1];
               ans++;
            }
            else u=ch[u][c];
        }
        return ans;
    }
};
Tire a;
int num[1005];
int main(){
    int t;
    scanf("%d",&t);
    while(t--){
       int n;
       scanf("%d",&n);
       a.init();
       for(int i=1;i<=n;i++){
            scanf("%d",&num[i]);
            a.T_insert(num[i],1);
       }
       LL ans=0;
       for(int i=1;i<=n;i++){
            a.T_insert(num[i],-1);
            for(int j=i+1;j<=n;j++){
                a.T_insert(num[j],-1);
                ans=max(ans,a.query(num[i]+num[j]));
                a.T_insert(num[j],1);
            }
            a.T_insert(num[i],1);
       }
       printf("%I64d\n",ans);
    }
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值