jobdu1046:求最大值

http://ac.jobdu.com/problem.php?pid=1046

题目描述:

输入10个数,要求输出其中的最大值。

输入:

测试数据有多组,每组10个数。

输出:

对于每组输入,请输出其最大值(有回车)。

样例输入:
10 22 23 152 65 79 85 96 32 1
样例输出:
max=152
 
 
#include <stdio.h>
#include <algorithm>
using namespace std;
int main() {
    int max = -99999999;
    int i = 0, a;
    while(scanf("%d", &a) != EOF) {
        if(a > max)
            max = a;
        if(++i%10 == 0) {
            printf("max=%d\n", max);
            max = -99999999;
        }
    }
    return 0;
}


 
 
#include <iostream>
#include <algorithm>
using namespace std;
int main() {
    int a[10];
    while(cin >> a[0] >> a[1] >> a[2] >> a[3] >> a[4] >> a[5] >> a[6] >> a[7] >> a[8] >> a[9]) {
        sort(a, a+10);
        cout << "max=" << a[9] << endl;
        }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值