POJ-1328 Radar Installation

Radar Installation
英文原题
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 97046 Accepted: 21574
Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output

Case 1: 2
Case 2: 1
Source

Beijing 2002

题目描述
中文原题

描述:

假设海岸线是一条无限延伸的直线。它的一侧是陆地,另一侧是海洋。每一座小岛是在海面上的一个点。雷达必须安装在陆地上(包括海岸线),并且每个雷达都有相同的扫描范围d。你的任务是建立尽量少的雷达站,使所有小岛都在扫描范围之内。

数据使用笛卡尔坐标系,定义海岸线为x轴。在x轴上方为海洋,下方为陆地。

样例1如图所示

这里写图片描述

输入格式:
第一行包括2个整数n和d,n是岛屿数目,d是雷达扫描范围。

接下来n行为岛屿坐标。

输出格式:
一个整数表示最少需要的雷达数目,若不可能覆盖所有岛屿,输出“-1”。

输入样例
3 2
1 2
-3 1
2 1
输出样例
2

题解
我们和容易想到的就是雷达肯定要放在海岸线(x轴)上。对于每个小岛,我们可以以它为圆心,以雷达扫描范围为半径作圆,如果雷达不在圆外,那么就可以扫描到这个岛。

由于我们的雷达肯定要放在 x轴 上,所以雷达的放置范围变成了一条条线段,而我们要求的就是使每条线段都包括点的时候,点的最小个数。这是很典型的贪心。

按照线段的右端点从小到大排序,用一个 lst 表示上一个雷达的位置,如果当前线段的左端点小于等于 lst,那么说明 lst 已经是这条线段上的点了,否则,我们肯定需要一个新的雷达,由于前面的都已经满足条件了,为了尽可能 使这个点 让后面更多地符合条件,所以最好放在当前线段的最右边。

这里写图片描述

无解的情况要小心(即到岸的距离大于 b 时),因为根号下不可以是负数。

代码

#include<cmath>
#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
const int maxn=1005;
int n,b,ans,sum;
struct js{
    double x,y;
}a[maxn];
double sqr(int x){return (double)x*x;}
double sqr(double x){return x*x;}
bool check(js &ai)
{
    double f=sqr(b)-sqr(ai.y);  
    if (f<0) return 1;
    f=sqrt(f);
    ai.y=ai.x+f;ai.x=ai.x-f;
    return 0;
}
bool cmp(js x,js y){return x.y<y.y||(x.y==y.y&&x.x>y.x);}
void work(int tes)
{
    scanf("%d%d",&n,&b);if (!n&&!b) return;
    for (int i=1;i<=n;i++) {scanf("%lf%lf",&a[i].x,&a[i].y);if (check(a[i])) b=-1;}
    if (b<0) {printf("Case %d: -1\n",tes);return;}
    sort(a+1,a+n+1,cmp);
    ans=1;double lst=a[1].y;
    for (int i=2;i<=n;i++)
    {
        if (a[i].x>lst)
        lst=a[i].y,ans++;
    }
    printf("Case %d: %d\n",tes,ans);
}
int main()
{
    int tes=0;
    while (true) {work(++tes);if (!n&&!b) break;}
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值