POJ 2406 Power Strings

这道题目的意思是如果一个字符串可以由若干个连续的子串组成,比如aaaa是有四个a组成所以是a^4,所以输出4。但是aasaasaa应该输出1因为aas这个循环节循环不到最后、、、所以解题思路就很清晰了啊、、

就是找到最后一个的循环节,p = len-next[len],如果len%p==0,说明是循环节。否则这不是整个的循环节、输出1。

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 28388 Accepted: 11867

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3
#include <stdio.h>
#include <string.h>
#include <cmath>
#include <iostream>
#include <string>

using namespace std;

int next[1010000];
string str;

int main()
{
    int len, i, j;
    while(cin >>str)
    {
        len = str.length();
        if(len == 1 && str[0] == '.')
            break;
        next[0] = 0;
        next[1] = 0;
        for(i = 1; i < len; i++)
        {
            j = next[i];
            while(j && str[i]!= str[j])
                j = next[j];
            if(str[i] == str[j])
                next[i+1] = j+1;
            else
                next[i+1] = 0;
        }
        if(len%(len-next[len]))
            cout <<'1'<<endl;
        else
            cout <<len/(len-next[len])<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值