FZU 1011 Power Strings(KMP匹配算法)

Problem 1011 Power Strings
Accept: 914 Submit: 2751
Time Limit: 1000 mSec Memory Limit : 32768 KB

Problem Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = “abc” and b = “def” then a*b = “abcdef”. If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = “” (the empty string) and a^(n+1) = a*(a^n).

Each test case is a line of input representing s, a string of printable characters. For each s you should print the largest n such that s = a^n for some string a. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Sample Input

abcd
aaaa
ababab
.
Sample Output

1
4
3

本题为简单的KMP匹配算法,,是我在KMP这个算法中做的第一道题.
下面是我的AC代码

#include<cstdio>
#include<cstring>
#include<iostream>
#include<algorithm>
using namespace std;
char str[1000005];
int next[1000005];

int kmp()
{
    int i=0,j=-1;
    next[0]=-1;
    while(str[i])
    {
        if(j==-1||str[i]==str[j])
        {
            ++i;
            ++j;
            next[i]=j;
        }
        else j=next[j];
    }
    return j;
}

int main()
{
    while(gets(str)&&str[0]!='.')
    {

        int len=strlen(str);
        int r=len-kmp();
        if(len%r==0)
        {
            printf("%d\n",len/r);
        }
        else printf("1\n");
    }
    return 0;
}
  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值