POJ 1265 Area

46 篇文章 0 订阅
15 篇文章 0 订阅

这题是皮克定理的一道题目,先说一下皮克定理:

给定顶点座标均是整点(或正方形格点)的简单多边形,皮克定理说明了其面积A和内部格点数目i、边上格点数目b的关系:A = i + b/2 - 1。(摘自维基百科)
题目的意思是给你几个拐点,让你求出在多边形直线上的点的个数,多边形内部的点的个数,以及多边形的面积。叉乘可以求出面积,线上的点的个数可以直接求出,所以就可以算出内部的点的个数。求直线上点的个数有公式 n = gcd(x,y)-1;求出所有的点就行了。

Area
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 4383 Accepted: 1988

Description

Being well known for its highly innovative products, Merck would definitely be a good target for industrial espionage. To protect its brand-new research and development facility the company has installed the latest system of surveillance robots patrolling the area. These robots move along the walls of the facility and report suspicious observations to the central security office. The only flaw in the system a competitor抯 agent could find is the fact that the robots radio their movements unencrypted. Not being able to find out more, the agent wants to use that information to calculate the exact size of the area occupied by the new facility. It is public knowledge that all the corners of the building are situated on a rectangular grid and that only straight walls are used. Figure 1 shows the course of a robot around an example area. 

 
Figure 1: Example area. 

You are hired to write a program that calculates the area occupied by the new facility from the movements of a robot along its walls. You can assume that this area is a polygon with corners on a rectangular grid. However, your boss insists that you use a formula he is so proud to have found somewhere. The formula relates the number I of grid points inside the polygon, the number E of grid points on the edges, and the total area A of the polygon. Unfortunately, you have lost the sheet on which he had written down that simple formula for you, so your first task is to find the formula yourself. 

Input

The first line contains the number of scenarios. 
For each scenario, you are given the number m, 3 <= m < 100, of movements of the robot in the first line. The following m lines contain pairs 揹x dy�of integers, separated by a single blank, satisfying .-100 <= dx, dy <= 100 and (dx, dy) != (0, 0). Such a pair means that the robot moves on to a grid point dx units to the right and dy units upwards on the grid (with respect to the current position). You can assume that the curve along which the robot moves is closed and that it does not intersect or even touch itself except for the start and end points. The robot moves anti-clockwise around the building, so the area to be calculated lies to the left of the curve. It is known in advance that the whole polygon would fit into a square on the grid with a side length of 100 units. 

Output

The output for every scenario begins with a line containing 揝cenario #i:� where i is the number of the scenario starting at 1. Then print a single line containing I, E, and A, the area A rounded to one digit after the decimal point. Separate the three numbers by two single blanks. Terminate the output for the scenario with a blank line.

Sample Input

2
4
1 0
0 1
-1 0
0 -1
7
5 0
1 3
-2 2
-1 0
0 -3
-3 1
0 -3

Sample Output

Scenario #1:
0 4 1.0

Scenario #2:
12 16 19.0
#include <stdio.h>
#include <string.h>
#include <string>
#include <iostream>
#include <stdlib.h>
#include <cmath>

using namespace std;

struct node
{
    int x, y;
}f[1010];
int n;
int gcd(int x, int y)
{
    if(x == 0)
        return y;
    if(y == 0)
        return x;
    return gcd(y,x%y);
}
int xmul(node f1, node f2, node f3)
{
    return ((f2.x-f1.x)*(f3.y-f1.y) - (f3.x-f1.x)*(f2.y-f1.y));
}
int get_s()
{
    int s = 0;
    for(int i = 1; i < n-1; i++)
        s += xmul(f[0], f[i], f[i+1]);
    s = abs(s);
    return s;
}
int get_edge()
{
    int sum = 0;
    for(int i = 0; i < n; i++)
    {
        int xx = abs(f[i+1].x-f[i].x);
        int yy = abs(f[i+1].y-f[i].y);
        if(xx == 0 && yy == 0)
            sum += 0;
        else if(xx == 0)
            sum += yy-1;
        else if(yy == 0)
            sum += xx-1;
        else
            sum += gcd(xx,yy)-1;
    }
    return sum+n;
}
int main()
{
    int _case = 0, T;
    int i;
    cin >>T;
    while(T--)
    {
        cin >>n;
        f[0].x = 0;
        f[0].y = 0;
        int xx, yy;
        for(i = 1; i <= n; i++)
        {
            cin >>xx>>yy;
            f[i].x = xx+f[i-1].x;
            f[i].y = yy+f[i-1].y;
        }
        int s = get_s();
        int edge = get_edge();
        int in = (s+2-edge)/2;
        cout <<"Scenario #"<<++_case<<':'<<endl;
        cout <<in<<' '<<edge;
        printf(" %.1lf\n\n",s/2.0);
    }
    return 0;
}
 


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值