HDU 4597 Play Game(四维记忆化搜索)

126 篇文章 2 订阅

做之前问虎哥比赛的时候怎么过掉的,虎哥说秒过。感觉自己好水啊。。。。

四维记忆化搜索。决策的条件是如果你剩下的数越小你得到的数越大。dp[l1][r1][l2][r2]代表当前状态的最优的情况。

dp[l1][r1][l2][r2] = sum-{四种衍生出来的状态};

Play Game

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65535/65535 K (Java/Others)
Total Submission(s): 477    Accepted Submission(s): 285


Problem Description
Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?
 

Input
The first line contains an integer T (T≤100), indicating the number of cases. 
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer a i (1≤a i≤10000). The third line contains N integer b i (1≤b i≤10000).
 

Output
For each case, output an integer, indicating the most score Alice can get.
 

Sample Input
  
  
2 1 23 53 3 10 100 20 2 4 3
 

Sample Output
  
  
53 105
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 1000100
#define LL __int64
//#define LL long long
#define INF 0x3f3f3f3f
#define PI 3.1415926535898

using namespace std;

const int maxn = 5000010;

int dp[30][30][30][30];
int num1[30], num2[30];
int cnt1[30], cnt2[30];
int dfs(int l1, int r1, int l2, int r2)
{
    if(dp[l1][r1][l2][r2] != 0)
        return dp[l1][r1][l2][r2];
    int sum = (cnt1[r1]-cnt1[l1-1]) + (cnt2[r2]-cnt2[l2-1]);
    if(l1 > r1 && l2 > r2)
        return 0;
    if(l1 > r1)
    {
        dp[l1][r1][l2][r2] = sum - min(dfs(l1, r1, l2+1, r2), dfs(l1, r1, l2, r2-1));
        return dp[l1][r1][l2][r2];
    }
    if(l2 > r2)
    {
        dp[l1][r1][l2][r2] = sum - min(dfs(l1+1, r1, l2, r2), dfs(l1, r1-1, l2, r2));
        return dp[l1][r1][l2][r2];
    }
    dp[l1][r1][l2][r2] = sum-(min(dfs(l1+1, r1, l2, r2),min(dfs(l1, r1-1, l2, r2), min(dfs(l1, r1, l2+1, r2), dfs(l1, r1, l2, r2-1)))));
    return dp[l1][r1][l2][r2];
}

int main()
{
    int T;
    cin >>T;
    while(T--)
    {
        int n;
        cin >>n;
        memset(dp, 0, sizeof(dp));
        memset(cnt1, 0, sizeof(cnt1));
        memset(cnt2, 0, sizeof(cnt2));
        for(int i = 1; i <= n; i++)
            cin >>num1[i];
        for(int i = 1; i <= n; i++)
            cin >>num2[i];
        for(int i = 1; i <= n; i++)
        {
           cnt1[i] += cnt1[i-1]+num1[i];
           cnt2[i] += cnt2[i-1]+num2[i];
        }
        dfs(1, n, 1, n);
        cout<<dp[1][n][1][n]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值