HDU 4597

                                                       HDU 4597

Alice and Bob are playing a game. There are two piles of cards. There are N cards in each pile, and each card has a score. They take turns to pick up the top or bottom card from either pile, and the score of the card will be added to his total score. Alice and Bob are both clever enough, and will pick up cards to get as many scores as possible. Do you know how many scores can Alice get if he picks up first?

Input

The first line contains an integer T (T≤100), indicating the number of cases. 
Each case contains 3 lines. The first line is the N (N≤20). The second line contains N integer ai(1≤ai≤10000). The third line contains N integer bi (1≤bi≤10000).

Output

For each case, output an integer, indicating the most score Alice can get.

Sample Input

2 
 
1 
23 
53 
 
3 
10 100 20 
2 4 3 

Sample Output

53 
105 

题意:两人玩游戏,两堆牌上面有数字,两人轮流拿牌,每次只能拿顶牌或底牌,问Alice是先手最多可以拿多少分?(分数为所拿牌数字之和)

状态:  dp[l1][r1][l2][r2]: Alice在第一堆区间为[l1][r1],第二堆区间为[l2][r2] 能拿到最多的分数。

dp[l1][r1][l2][r2]由以下四种状态转移而来:

dp[l1+1][r1][l2][r2]、dp[l1][r1-1][l2][r2]、dp[l1][r1][l2+1][r2]、dp[l1][r1][l2][r2-1]  

上述四种转态也是Bob所拿的分数且有Alice=sum(l1,r1,l2,r2) - Bob

要使得Alice最多,Bob应该选四种状态最少的。

即dp[l1+1][r1][l2][r2]=sum(l1,r1,l2,r2)-min{dp[l1+1][r1][l2][r2]、dp[l1][r1-1][l2][r2]、dp[l1][r1][l2+1][r2]、dp[l1][r1][l2][r2-1]  }

递归记忆搜索

#include <iostream>
#include<cstring>
using namespace std;
const int N=25;
int dp[N][N][N][N];
int sum1[N],sum2[N];
int fun(int l1, int r1, int l2, int r2){//递归记忆化搜索
    int ans=0;
    if(dp[l1][r1][l2][r2]>0){//已经计算过
       return dp[l1][r1][l2][r2];
    }
    if(l1>r1&&l2>r2)
    {
        return 0;
    }
    if(l1<=r1){
        int k=min(fun(l1+1,r1,l2,r2),fun(l1,r1-1,l2,r2));
        ans=max(ans,sum1[r1]-sum1[l1-1]+sum2[r2]-sum2[l2-1]-k);
    }
    if(l2<=r2){
        int k=min(fun(l1,r1,l2+1,r2),fun(l1,r1,l2,r2-1));
        ans=max(ans,sum1[r1]-sum1[l1-1]+sum2[r2]-sum2[l2-1]-k);
    }
    dp[l1][r1][l2][r2]=ans;
    return dp[l1][r1][l2][r2];
}
int main()
{
    int n,t,a;
    cin>>t;
    while(t--){
       cin>>n;
       sum1[0]=sum2[0]=0;
       memset(dp,0,sizeof(dp));
       for(int i=1; i<=n; i++){
           cin>>a;
           sum1[i]=sum1[i-1]+a;
       }
       for(int i=1; i<=n; i++){
           cin>>a;
           sum2[i]=sum2[i-1]+a;
       }
       cout<<fun(1,n,1,n)<<endl;
    }
    return 0;
}

 

  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值