ZOJ 3777(状压dp)

23 篇文章 0 订阅

浙江省赛的题目,当时做的同步赛,以为是dfs,结果各种超时。后来听芳姐说这是状压。

注意一下:这里是n*n的矩阵所以选了第j列就一定选择过了j行了啊。然后状压枚举状态,递推下去。如果结果已经大于m了就让他=m。只记住有多少中情况就行了啊。

Problem Arrangement

Time Limit: 2 Seconds       Memory Limit: 65536 KB

The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer T indicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output "No solution" instead.

Sample Input
2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4
Sample Output
3/1
No solution
#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-7
#define M 1000100
#define LL __int64
//#define LL long long
#define INF 0x3fffffff
#define PI 3.1415926535898
#define MOD 1000000007

using namespace std;

const int maxn = 1100;

int dp[4500][520];
int mp[14][14];
int n, m;

int judge(int x)
{
    int cnt = 0;
    for(int i = 0; i < n; i++)
    {
        if((1<<i)&x)
            cnt ++;
    }
    return cnt;
}

int main()
{
    int T;
    cin >>T;
    while(T--)
    {
        cin >>n>>m;
        for(int i = 1; i <= n; i++)
            for(int j = 0; j < n; j++)
                cin >>mp[i][j];
        memset(dp, 0 , sizeof(dp));
        dp[0][0] = 1;
        for(int i = 0; i <= ((1<<n)-1); i++)
        {
            int x = judge(i);
            for(int j = 0; j < n; j++)
            {
                if(((1<<j)&i) == 0)
                {
                    for(int g = 0; g <= m; g++)
                    {
                        int y = g+mp[x+1][j];
                        if(y >= m)
                            y = m;
                        dp[i+(1<<j)][y] += dp[i][g];
                    }
                }
            }
        }
        int sum = 0;
        sum += dp[(1<<n)-1][m];
        if(sum == 0)
        {
            cout<<"No solution"<<endl;
            continue;
        }
        int ans = 1;
        for(int i = 1; i <= n; i++)
            ans *= i;
        int x = __gcd(sum, ans);
        cout<<ans/x<<"/"<<sum/x<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值