Problem Arrangement ZOJ - 3777

The 11th Zhejiang Provincial Collegiate Programming Contest is coming! As a problem setter, Edward is going to arrange the order of the problems. As we know, the arrangement will have a great effect on the result of the contest. For example, it will take more time to finish the first problem if the easiest problem hides in the middle of the problem list.

There are N problems in the contest. Certainly, it's not interesting if the problems are sorted in the order of increasing difficulty. Edward decides to arrange the problems in a different way. After a careful study, he found out that the i-th problem placed in the j-th position will add Pij points of "interesting value" to the contest.

Edward wrote a program which can generate a random permutation of the problems. If the total interesting value of a permutation is larger than or equal to M points, the permutation is acceptable. Edward wants to know the expected times of generation needed to obtain the first acceptable permutation.

Input

There are multiple test cases. The first line of input contains an integer Tindicating the number of test cases. For each test case:

The first line contains two integers N (1 <= N <= 12) and M (1 <= M <= 500).

The next N lines, each line contains N integers. The j-th integer in the i-th line is Pij (0 <= Pij <= 100).

Output

For each test case, output the expected times in the form of irreducible fraction. An irreducible fraction is a fraction in which the numerator and denominator are positive integers and have no other common divisors than 1. If it is impossible to get an acceptable permutation, output "No solution" instead.

Sample Input
2
3 10
2 4 1
3 2 2
4 5 3
2 6
1 3
2 4
Sample Output
3/1
No solution

题意:有n道题,给你第i道题放在第j个位置上的趣味值。然后让你求出趣味值大于等于m的安排方案。

求出来之后就是分子,然后分母就是n的阶乘,两个求一下gcd。

重点是怎么求方案数,最容易想到的就是dfs。然而这12的阶乘的复杂度暴力不能啊。

正解是状压dp,看了看题解之后交的。

代码量不大,看看就懂啦。当然dp那部分看了一下午也是稍稍理解了下。

#include <iostream>
#include <cstdio>
#include <cstring>
#include <algorithm>
using namespace std;
const int MAXN=15;
int n,m;
int lie[MAXN];
int tu[MAXN][MAXN];
int dp[1<<13][1250];//状态为i,趣味值为j的
int ans;
int gcd(int a,int b)
{
    return b?gcd(b,a%b):a;
}
void get_dp()
{
    dp[0][0]=1;
    for(int i=0; i<(1<<n); i++)
    {
        int num=0;
        for(int j=0; j<n; j++)
        {
            if(i&(1<<j)) num++;//1的个数
        }
        for(int j=0; j<n; j++)
        {
            if(i&(1<<j)) continue;//选过的位置就不用选了
            for(int k=0; k<=m; k++)//转移方程
            {
                if(k+tu[num][j]>=m)
                {
                    dp[i|(1<<j)][m]+=dp[i][k];
                }
                else
                {
                    dp[i|(1<<j)][k+tu[num][j]]+=dp[i][k];
                }
            }
        }
    }
}
int cheng(int n)
{
    int sum=1;
    for(int i=2; i<=n; ++i)sum*=i;
    return sum;
}
int main()
{
    int i,j;
    int t;
    scanf("%d",&t);
    while(t--)
    {
        memset(dp,0,sizeof(dp));
        memset(lie,0,sizeof(lie));
        scanf("%d%d",&n,&m);
        for(i=0; i<n; ++i)
            for(j=0; j<n; ++j)scanf("%d",&tu[i][j]);
        get_dp();
        int ans=dp[(1<<n)-1][m];
        if(!ans)puts("No solution");
        else
        {
            int fenmu=cheng(n);
            int x=gcd(fenmu,ans);
            ans/=x;
            fenmu/=x;
            printf("%d/%d\n",fenmu,ans);
        }
    }
    return 0;
}



  • 1
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值