HDU 4891 The Great Pan(模拟)

题目的意思还是比较好看懂的。注意以下几点:

1.所有的{}与$$都是唯一匹配的啊,$$ $$这种情况按前两个一组后两个一组来算。

2.换行不会打破连续的空格。

3.{}与$$之间的不会有嵌套的形式。

4.中间计算过程有可能超int要用long long 来存。

The Great Pan

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 485    Accepted Submission(s): 188


Problem Description
As a programming contest addict, Waybl is always happy to take part in various competitive programming contests. One day, he was competing at a regional contest of Inventing Crappy Problems Contest(ICPC). He tried really hard to solve a "geometry" task without success.

After the contest, he found that the problem statement is ambiguous! He immediately complained to jury. But problem setter, the Great Pan, told him "There are only four possibilities, why don't you just try all of them and get Accepted?".

Waybl was really shocked. It is the first time he learned that enumerating problem statement is as useful as trying to solve some ternary search problem by enumerating a subset of possible angle!

Three years later, while chatting with Ceybl, Waybl was told that some problem "setters" (yeah, other than the Great Pan) could even change the whole problem 30 minutes before the contest end! He was again shocked.

Now, for a given problem statement, Waybl wants to know how many ways there are to understand it.

A problem statement contains only newlines and printable ASCII characters (32 ≤ their ASCII code ≤ 127) except '{', '}', '|' and '$'.

Waybl has already marked all ambiguity in the following two formats:

1.{A|B|C|D|...} indicates this part could be understand as A or B or C or D or ....
2.$blah blah$ indicates this part is printed in proportional fonts, it is impossible to determine how many space characters there are.

Note that A, B, C, D won't be duplicate, but could be empty. (indicate evil problem setters addedclarified it later.)

Also note that N consecutive spaces lead to N+1 different ways of understanding, not 2 N ways.

It is impossible to escape from "$$" and "{}" markups even with newlines. There won't be nested markups, i.e. something like "${A|B}$" or "{$A$|B}" or "{{A|B}|C}" is prohibited. All markups will be properly matched.
 

Input
Input contains several test cases, please process till EOF.
For each test case, the first line contains an integer n, indicating the line count of this statement. Next n lines is the problem statement.
1 ≤ n ≤ 1000, size of the input file will not exceed 1024KB.
 

Output
For each test case print the number of ways to understand this statement, or "doge" if your answer is more than  105.
 

Sample Input
  
  
9 I'll shoot the magic arrow several times on the ground, and of course the arrow will leave some holes on the ground. When you connect three holes with three line segments, you may get a triangle. {|It is hole! Common sense!| No Response, Read Problem Statement|don't you know what a triangle is?} 1 Case $1: = >$ 5 $/*This is my code printed in proportional font, isn't it cool?*/ printf("Definitely it is cooooooool \ %d\n",4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4 * 4);$ 2 $Two space$ and {blue| red} color!
 

Sample Output
  
  
4 4 doge 6
 

Author
Fudan University
 

Source
#include <stdio.h>
#include <string.h>
#include <iostream>
#include <algorithm>
#include <vector>
#include <queue>
#include <set>
#include <map>
#include <string>
#include <math.h>
#include <stdlib.h>
#define clear(A, X, SIZE) memset(A, X, sizeof(A[0]) * (SIZE))
#define clearall(A, X) memset(A, X, sizeof(A))
#define max( x, y )  ( ((x) > (y)) ? (x) : (y) )
#define min( x, y )  ( ((x) < (y)) ? (x) : (y) )
#define LL long long
#define maxn 1e5
using namespace std;

int main()
{
    int n;
    LL ans,temp,cnt;
    char c, x;
    while(~scanf("%d",&n))
    {
        x=getchar();
        while(x!='\n')
        {
            x=getchar();
        }
        bool flat1=false,flat2=false,flat=true;
        ans=1;
        temp=1;
        while(n--)
        {
            while(1)
            {
                scanf("%c",&c);
                if(c == '\n')
                    break;
                if(flat)
                {
                    if(ans>maxn || temp > maxn)
                    {
                        ans=maxn+10;
                        flat=false;
                        continue;
                    }
                    if(c=='{')
                    {
                        flat1=true;
                        cnt=1;
                    }
                    else if(c=='}')
                    {
                        ans*=cnt;
                        flat1=false;
                    }
                    else if(flat1&&c=='|')
                    {
                        cnt++;
                    }
                    else if(!flat2&&c=='$')
                    {
                        flat2=true;
                        temp=1;
                        cnt=1;
                    }
                    else if(flat2&&c=='$')
                    {
                        temp*=cnt;
                        ans*=temp;
                        flat2=false;
                    }
                    else if(flat2&&c==' ')
                    {
                        cnt++;
                    }
                    else if(flat2&&c!=' ')
                    {
                        temp*=cnt;
                        cnt=1;
                    }
                }
            }
        }
        if(ans>maxn)puts("doge");
        else printf("%I64d\n",ans);
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值