HDU 4925 Apple Tree (瞎搞)

找到规律,各一个种一棵树,或者施肥。先施肥,先种树一样。

Apple Tree

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 262144/262144 K (Java/Others)
Total Submission(s): 197    Accepted Submission(s): 135


Problem Description
I’ve bought an orchard and decide to plant some apple trees on it. The orchard seems like an N * M two-dimensional map. In each grid, I can either plant an apple tree to get one apple or fertilize the soil to speed up its neighbors’ production. When a grid is fertilized, the grid itself doesn’t produce apples but the number of apples of its four neighbor trees will double (if it exists). For example, an apple tree locates on (x, y), and (x - 1, y), (x, y - 1) are fertilized while (x + 1, y), (x, y + 1) are not, then I can get four apples from (x, y). Now, I am wondering how many apples I can get at most in the whole orchard?
 

Input
The input contains multiple test cases. The number of test cases T (T<=100) occurs in the first line of input.
For each test case, two integers N, M (1<=N, M<=100) are given in a line, which denote the size of the map.
 

Output
For each test case, you should output the maximum number of apples I can obtain.
 

Sample Input
  
  
2 2 2 3 3
 

Sample Output
  
  
8 32
 

#include <algorithm>
#include <iostream>
#include <stdlib.h>
#include <string.h>
#include <iomanip>
#include <stdio.h>
#include <string>
#include <queue>
#include <cmath>
#include <stack>
#include <map>
#include <set>
#define eps 1e-12
///#define M 1000100
#define LL __int64
///#define LL long long
///#define INF 0x7ffffff
#define INF 0x3f3f3f3f
#define PI 3.1415926535898
#define zero(x) ((fabs(x)<eps)?0:x)

using namespace std;


const int maxn = 110;

int mp[maxn][maxn];

int main()
{
    int n, m;
    int T;
    cin >>T;
    while(T--)
    {
        scanf("%d %d",&n, &m);
        memset(mp, 0, sizeof(mp));
        for(int i = 1; i <= n; i++)
        {
            if(i%2)
            {
                for(int j = 1; j <= m; j += 2)
                    mp[i][j] = 1;
            }
            else
            {
                for(int j = 2; j <= m; j+= 2)
                    mp[i][j] = 1;
            }
        }
        LL sum = 0;
        for(int i = 1; i <= n; i++)
        {
            for(int j = 1; j <= m; j++)
            {
                if(mp[i][j]) continue;
                int cnt = 0;
                if(i-1 >= 1) if(mp[i-1][j]) cnt ++;
                if(i+1 <= n) if(mp[i+1][j]) cnt ++;
                if(j-1 >= 1) if(mp[i][j-1]) cnt++;
                if(j+1 <= m) if(mp[i][j+1]) cnt++;
                sum += (1LL<<cnt);
            }
        }
        if(sum == 0)
            sum++;
        cout<<sum<<endl;
    }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值