ZOJ 2048 POJ 1751 Highways

The island nation of Flatopia is perfectly flat. Unfortunately, Flatopia has a very poor system of public highways. The Flatopian government is aware of this problem and has already constructed a number of highways connecting some of the most important towns. However, there are still some towns that you can't reach via a highway. It is necessary to build more highways so that it will be possible to drive between any pair of towns without leaving the highway system. 

Flatopian towns are numbered from 1 to N and town i has a position given by the Cartesian coordinates (xi, yi). Each highway connects exaclty two towns. All highways (both the original ones and the ones that are to be built) follow straight lines, and thus their length is equal to Cartesian distance between towns. All highways can be used in both directions. Highways can freely cross each other, but a driver can only switch between highways at a town that is located at the end of both highways. 

The Flatopian government wants to minimize the cost of building new highways. However, they want to guarantee that every town is highway-reachable from every other town. Since Flatopia is so flat, the cost of a highway is always proportional to its length. Thus, the least expensive highway system will be the one that minimizes the total highways length. 
Input
The input consists of two parts. The first part describes all towns in the country, and the second part describes all of the highways that have already been built. 

The first line of the input file contains a single integer N (1 <= N <= 750), representing the number of towns. The next N lines each contain two integers, xi and yi separated by a space. These values give the coordinates of i  th town (for i from 1 to N). Coordinates will have an absolute value no greater than 10000. Every town has a unique location. 

The next line contains a single integer M (0 <= M <= 1000), representing the number of existing highways. The next M lines each contain a pair of integers separated by a space. These two integers give a pair of town numbers which are already connected by a highway. Each pair of towns is connected by at most one highway. 
Output
Write to the output a single line for each new highway that should be built in order to connect all towns with minimal possible total length of new highways. Each highway should be presented by printing town numbers that this highway connects, separated by a space. 

If no new highways need to be built (all towns are already connected), then the output file should be created but it should be empty. 
Sample Input
9
1 5
0 0 
3 2
4 5
5 1
0 4
5 2
1 2
5 3
3
1 3
9 7
1 2
Sample Output
1 6
3 7
4 9
5 7

8 3

题意:修高速,把所有城市相互连接起来,即得到一个最小生成树。有的路未修,有的路已修。输出连接所有城市需要再修的最短路径中每条路城市与城市的序号。

题解:

求最小生成树,可用Kruskal与Prim算法。代码很容易超时,最好注意数组的大小,代码的复杂度。多测试对数据的处理是否正确。the output file should be created but it should be empty. 这句话无用。

输出结果左右节点可以颠倒,每行数据上下位置可颠倒。此代码Poj上g++提交ac,c++超时。

Kruskal算法代码:

/*必须要用两个结构体,分开;*/
#include<stdio.h>
#include<string.h>
#include<math.h>
#include<algorithm>
using namespace std;

int f[2000];

struct node
{
    double x,y;
    double s;
} q[1110000];

struct note
{
    int a,b;
    double s;
}p[1110000];

double cmp(note T1,note T2)
{
    return T1.s<T2.s;
}

int fun(int aa,int bb)
{
    double T=(q[aa].x-q[bb].x)*(q[aa].x-q[bb].x)+(q[aa].y-q[bb].y)*(q[aa].y-q[bb].y);
    return T;
}

int getf(int x)
{
    if(f[x]==x)
        return x;
    else
    {
        f[x]=getf(f[x]);
        return f[x];
    }
}

int merg(int x,int y)
{
    int t1=getf(x);
    int t2=getf(y);
    if(t1!=t2)
    {
        f[t2]=t1;
        return 1;
    }
    return 0;
}

int main()
{
    int n,h=1;
    while(~scanf("%d",&n))
    {
        int i,j,m,xx,yy;
        for(i=1; i<=n; i++)
            f[i]=i;
        for(i=1; i<=n; i++)
            scanf("%lf%lf",&q[i].x,&q[i].y);
        scanf("%d",&m);
        for(i=0; i<m; i++)
        {
            scanf("%d%d",&xx,&yy);
            merg(xx,yy);
        }
        int u=0,sum=0,num=0;
        for(i=1; i<=n; i++)//这段减少复杂度,否则易超时;
            for(j=i+1; j<=n; j++)
            {
                if(i==j)
                    continue;
                p[u].a=i;
                p[u].b=j;
                p[u].s=fun(i,j);
                u++;
                p[u].a=j;
                p[u].b=i;
                p[u].s=fun(j,i);
                u++;
            }

        sort(p,p+u,cmp);
        for(i=0; i<u; i++)
        {
            int ff=p[i].a;
            int gg=p[i].b;
            if(merg(ff,gg))
            {
                sum++;
                printf("%d %d\n",ff,gg);
                num++;
            }
            if(num==n-1)
                break;
        }
        if(sum==0)
            printf("\n");
    }
}



Prim算法代码:

#include<stdio.h>
#include<string.h>
#include<math.h>
int n,m,i,j,k,t1,t2,t3;
int e[1100][1100],dis[1100],book[1100];
int inf=9999999999,path[1100];
int sum,x[1100],y[1100],ss;
void prim()
{
    memset(book,0,sizeof(book));
    for(i=1; i<=n; i++)
    {
        dis[i]=e[1][i];
        path[i]=1;
    }
    book[1]=1;
    dis[1]=0;
    for(i=1; i<=n; i++)
    {
        k=0;
        int min=inf;
        for(j=1; j<=n; j++)
        {
            if(book[j]==0 && min>dis[j])
            {
                min=dis[j];
                k=j;
            }
        }
        book[k]=1;
        if(e[path[k]][k]!=0)
            printf("%d %d\n",k,path[k]);
        for(j=1; j<=n; j++)
        {
            if(book[j]==0&&dis[j]>e[k][j])
            {
                dis[j]=e[k][j];
                path[j]=k;
            }
        }
        book[j]=1;
    }
}
int main()
{
    while(~scanf("%d",&n))
    {
        int a,b;
        ss=0;
        for(i=1; i<=n; i++)
        {
            scanf("%d%d",&x[i],&y[i]);
            for(j=1; j<=n; j++)
            {
                e[i][j]=e[j][i]=(x[i]-x[j])*(x[i]-x[j])+(y[i]-y[j])*(y[i]-y[j]);
            }
        }
        scanf("%d",&m);
        for(i=1; i<=m; i++)
        {
            scanf("%d%d",&a,&b);
            e[a][b]=e[b][a]=0;
        }
        prim();

    }
    return 0;
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值