Meteor Shower POJ - 3669 广搜

Bessie hears that an extraordinary meteor shower is coming; reports say that these meteors will crash into earth and destroy anything they hit. Anxious for her safety, she vows to find her way to a safe location (one that is never destroyed by a meteor) . She is currently grazing at the origin in the coordinate plane and wants to move to a new, safer location while avoiding being destroyed by meteors along her way.

The reports say that M meteors (1 ≤ M ≤ 50,000) will strike, with meteor i will striking point (XiYi) (0 ≤ X≤ 300; 0 ≤ Y≤ 300) at time Ti (0 ≤ Ti  ≤ 1,000). Each meteor destroys the point that it strikes and also the four rectilinearly adjacent lattice points.

Bessie leaves the origin at time 0 and can travel in the first quadrant and parallel to the axes at the rate of one distance unit per second to any of the (often 4) adjacent rectilinear points that are not yet destroyed by a meteor. She cannot be located on a point at any time greater than or equal to the time it is destroyed).

Determine the minimum time it takes Bessie to get to a safe place.

Input

* Line 1: A single integer: M
* Lines 2..M+1: Line i+1 contains three space-separated integers: XiYi, and Ti

Output

* Line 1: The minimum time it takes Bessie to get to a safe place or -1 if it is impossible.

Sample Input
4
0 0 2
2 1 2
1 1 2
0 3 5
Sample Output

5


题意:

一个人需要从起始点找到安全区域。题中给出m个坐标点和其将被轰炸的时间,这个点和其周围的四个点也会被轰炸。轰炸过的点永远也不能走过。

题解:

将各个坐标点及其周围的点取其轰炸时间的最小值,其他点的值初始化为-1,因为轰炸过的点不能走。从起始点0,0开始应用广搜,计算已用的时间,判断下一步是未轰炸还是已轰炸。未轰炸可走。碰到不会被轰炸的点,即标记为-1的点,返回所用的时间。注意有两个特殊情况,起始点在0时被轰炸,起始点为安全区。


代码如下:

#include<stdio.h>
#include<string.h>
#include<queue>
#include<algorithm>
using namespace std;
int vis[330][330];
int nt[5][2]= {{0,0},{1,0},{0,1},{-1,0},{0,-1}};
struct node
{
    int x,y,t;
};
int bfs()
{
    queue<node>Q;
    node now,tmp;
    if(vis[0][0]==0) return -1;
    else if(vis[0][0]==-1) return 0;
    now.x=0;
    now.y=0;
    now.t=0;
    Q.push(now);
    while(!Q.empty())
    {
        now=Q.front();
        Q.pop();
        for(int i=1; i<5; i++)
        {
            tmp=now;
            int tx=tmp.x+nt[i][0];
            int ty=tmp.y+nt[i][1];
            if(tx<0 || ty<0) continue;
            if(vis[tx][ty]==-1)  return  (tmp.t+1);
            if((tmp.t+1)>=vis[tx][ty]) continue;
            vis[tx][ty]=0;
            tmp.x=tx;
            tmp.y=ty;
            tmp.t+=1;
            Q.push(tmp);
        }
    }
    return -1;
}

int main()
{
    int m,k,t,x,y,x1,y1;
    scanf("%d",&m);
    memset(vis,-1,sizeof(vis));
    for(int j=0; j<m; j++)
    {
        scanf("%d%d%d",&x,&y,&t);
        for(int i=0; i<=4; i++)
        {
            x1=x+nt[i][0];
            y1=y+nt[i][1];
            if(x1<0 || y1<0) continue;
            if(vis[x1][y1]==-1)
                vis[x1][y1]=t;
            else
                vis[x1][y1]=min(vis[x1][y1],t);
        }
    }
    printf("%d\n",bfs());
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值