e-Coins

Problem E : e-Coins

From:UVA, 10306

Submit (Out Of Contest)

Time Limit: 3000 MS

Problem G

At the Department for Bills and Coins, an extension of today's monetary system has newly been proposed, in order to make it fit the new economy better. A number of new so called e-coins will be produced, which, in addition to having a value in the normal sense of today, also have an InfoTechnological value. The goal of this reform is, of course, to make justice to the economy of numerous dotcom companies which, despite the fact that they are low on money surely have a lot of IT inside. All money of the old kind will keep its conventional value and get zero InfoTechnological value.

To successfully make value comparisons in the new system, something called the e-modulus is introduced. This is calculated as SQRT(X*X+Y*Y), where X and Y hold the sums of the conventional and InfoTechnological values respectively. For instance, money with a conventional value of $3 altogether and an InfoTechnological value of $4 will get an e-modulus of $5. Bear in mind that you have to calculate the sums of the conventional and InfoTechnological values separately before you calculate the e-modulus of the money.

To simplify the move to e-currency, you are assigned to write a program that, given the e-modulus that shall be reached and a list of the different types of e-coins that are available, calculates the smallest amount of e-coins that are needed to exactly match the e-modulus. There is no limit on how many e-coins of each type that may be used to match the given e-modulus.

Input

A line with the number of problems n (0<n<=100), followed by n times:

  • A line with the integers m (0<m<=40) and S (0<S<=300), where m indicates the number of different e-coin types that exist in the problem, and S states the value of the e-modulus that shall be matched exactly.
  • m lines, each consisting of one pair of non-negative integers describing the value of an e-coin. The first number in the pair states the conventional value, and the second number holds the InfoTechnological value of the coin.

When more than one number is present on a line, they will be separated by a space. Between each problem, there will be one blank line.

 

Output

The output consists of n lines. Each line contains either a single integer holding the number of coins necessary to reach the specified e-modulus S or, if S cannot be reached, the string "not possible".

Sample Input:

3 
2 5 
0 2 
2 0

3 20 
0 2 
2 0 
2 1

3 5 
3 0 
0 4 
5 5

Sample Output:

not possible 
10 
2

题意是:一种钱币有2种价值X,Y,求对于指定的价值s,有没有相应的组成方案,如果有求出硬币数最小的数目。思路:二维展开对于dp[x][y]=min(dp[x-xi][y-yi]+1,dp[x][y]);然后根据题目的转换方法进行转换,判断是否组成相应的值,如果有,求个最小值。
#include<iostream>
#define maxn 310
using namespace std;
struct node{
    int cv,iv;
}coin[41];
int dp[maxn][maxn];
int min(int a,int b){
    return a<b?a:b;
}
int main(){
    int cont,n,m;
    while(cin>>cont){
        while(cont-->0){
           cin>>n>>m;
                for(int i=0;i<n;i++){
                    cin>>coin[i].cv>>coin[i].iv;
                }
                for(int i=0;i<=m;i++){
                    for(int j=0;j<=m;j++){
                        dp[i][j]=maxn;
                    }
                }
                dp[0][0]=0;
                for(int i=0;i<n;i++){
                    for(int j=coin[i].cv;j<=m;j++){
                        for(int k=coin[i].iv;k<=m;k++){
                            dp[j][k]=min(dp[j-coin[i].cv][k-coin[i].iv]+1,dp[j][k]);
                        }
                    }
                }
               //while(cin>>n>>m) cout<<dp[n][m]<<endl;
                int no=maxn;
                for(int i=0;i<=m;i++){
                    for(int j=0;j<=m;j++){
                        //cout<<dp[i][j]<<endl;
                        if(i*i+j*j==m*m){
                            no=min(no,dp[i][j]);
                        }
                    }
                }
                if(no==maxn) cout<<"not possible"<<endl;
                else cout<<no<<endl;
        }
    }
    return 0;
}







  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值