Bee

b

The Problem

In Africa there is a very special species of bee. Every year, the female bees of such species give birth to one male bee, while the male bees give birth to one male bee and one female bee, and then they die!

Now scientists have accidentally found one "magical female bee" of such special species to the effect that she is immortal, but still able to give birth once a year as all the other female bees. The scientists would like to know how many bees there will be after N years. Please write a program that helps them find the number of male bees and the total number of all bees after N years.

The Input

Each line of input contains an integer N (≥ 0). Input ends with a case where N = -1. (This case should NOT be processed.)

The Output

Each line of output should have two numbers, the first one being the number of male bees after N years, and the second one being the total number of bees after N years. (The two numbers will not exceed 232.)

Sample Input

1
3
-1

Sample Output

1 2
4 7
此题考查简单的数学推理,易得公式:f(n)=m(n-1)+1;m(n)=m(n-1)+f(n-1);主要的坑点在于数据的范围,要暴int,所以用unsigned int 或long long
判断是否结束打表,要用减法,而不是加法,因为用加法的话,会溢出。eg:a+b<2^32(false);a<2^32-b(T);当然也可以开大点数组,只要在测试范围内保证数据没有溢出就好了。
#include<iostream>
#define maxn 100
using namespace std;
unsigned int num[maxn],no[maxn];
int main(){
    num[0]=1;
    no[0]=0;
    num[1]=1;
    no[1]=1;
    for(int i=2;i<maxn;i++){
        num[i]=no[i-1]+1;
        no[i]=num[i-1]+no[i-1];
    }
    int n;
    while(cin>>n){
        if(n==-1) break;
        cout<<no[n]<<" "<<no[n]+num[n]<<endl;
    }
    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值