poj 3126 Prime Path(广搜)

题目链接:http://poj.org/problem?id=3126点击打开链接

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 21029 Accepted: 11707

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices. 
— It is a matter of security to change such things every now and then, to keep the enemy in the dark. 
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know! 
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door. 
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime! 
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds. 
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime. 

Now, the minister of finance, who had been eavesdropping, intervened. 
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound. 
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you? 
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above. 
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0
广搜就能解决 注意扩大搜索范围时 千位不为零 标记搜索过的即可
#include <stdio.h>
#include <stdlib.h>
#include <iostream>
#include<algorithm>
#include <math.h>
#include <string.h>
#include <limits.h>
#include <string>
#include <queue>
#include <stack>
using namespace std;
int n,m;
int isprime[10000];
int book[10000];
int num=0;
int flag=0;
void makeprime()
{
    for(int i=2;i<10000;i++)
    {
        int j=2*i;
        while(j<10000)
        {
            isprime[j]=1;
            j+=i;
        }
    }
}
void bfs()
{
    queue<int > q;
    q.push(n);
    book[n]=1;
    int mid;
    while(!q.empty())
    {
        mid=q.front();
        q.pop();
        if(mid==m)
        {
            flag=book[mid]-1;
            break;
        }
        for(int i=0;i<4;i++)
        {
            int midmid=mid;
            int ys=(int)pow(10,i);
            midmid-=(midmid%(int)pow(10,i+1)/ys)*ys;
            int ys1=0;
            if(i!=3)
                ys1=0;
            else
                ys1=1;
            for(int j=ys1;j<=9;j++)
            {
                int midmidmid=midmid;
                midmidmid+=j*(int)pow(10,i);
                if(!isprime[midmidmid]&&!book[midmidmid])
                {
                    book[midmidmid]=book[mid]+1;
                    q.push(midmidmid);
                }
            }
        }
        num++;
    }
}
int main()
{
    makeprime();
    int t=0;
    scanf("%d",&t);
    while(t--)
    {
        num=0;
        flag=0;
        for(int i=0;i<10000;i++)
            book[i]=0;
        scanf("%d%d",&n,&m);
        bfs();
        printf("%d\n",flag);
        
    }
}

又写了一遍 直接付代码了
#include <iostream>
#include <queue>
#include <stdio.h>
#include <stdlib.h>
#include <stack>
#include <limits>
#include <string>
#include <string.h>
#include <vector>
#include <set>
#include <map>
#include <algorithm>
#include <math.h>
using namespace std;
int prime[11111];
int book[11111];
int b,e;
int ans=0;
void isprime()
{
    for(int i=2;i<=10000;i++)
    {
        if(!prime[i])
            for(int j=i+i;j<=10000;j+=i)
                prime[j]=1;
    }
    prime[1]=1;
}
queue <int > q;
void bfs()
{
    while(!q.empty())
        q.pop();
    q.push(b);
    while(!q.empty())
    {
        int mid=q.front();
        q.pop();
        //cout << mid <<" ";
        if(mid==e)
        {
            break;
        }
        int mid1=mid/1000;
        int mid2=(mid-mid1*1000)/100;
        int mid3=(mid-mid1*1000-mid2*100)/10;
        int mid4=mid-mid1*1000-mid2*100-mid3*10;
        for(int i=0;i<=9;i++)
        {
            int midmid;
            midmid=mid-mid2*100+i*100;
            if(midmid!=mid&&!prime[midmid]&&(book[midmid]==-1))
            {
                q.push(midmid);
                book[midmid]=book[mid]+1;
            }
            midmid=mid-mid3*10+i*10;
            if(midmid!=mid&&!prime[midmid]&&(book[midmid]==-1))
            {
                q.push(midmid);
                book[midmid]=book[mid]+1;
            }
            midmid=mid-mid4*1+i*1;
            if(midmid!=mid&&!prime[midmid]&&(book[midmid]==-1))
            {
                q.push(midmid);
                book[midmid]=book[mid]+1;
            }
        }
        for(int i=1;i<=9;i++)
        {
            int midmid;
            midmid=mid-mid1*1000+i*1000;
            if(midmid!=mid&&!prime[midmid]&&(book[midmid]==-1))
            {
                q.push(midmid);
                book[midmid]=book[mid]+1;
            }
        }

    }
}
int main()
{
    isprime();
    int n=0;
    scanf("%d",&n);
    for(int ii=0;ii<n;ii++)
        {
            for(int i=0;i<10000;i++)
                book[i]=-1;
            cin >> b >> e;
            book[b]=0;
            bfs();
            if(b==e)
                book[e]=0;
            cout << book[e] << endl;

        }
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值