POJ 2299 Ultra-QuickSort

Ultra-QuickSort
Time Limit: 7000MS Memory Limit: 65536K
Total Submissions: 50447 Accepted: 18499

Description

In this problem, you have to analyze a particular sorting algorithm. The algorithm processes a sequence of n distinct integers by swapping two adjacent sequence elements until the sequence is sorted in ascending order. For the input sequence 
9 1 0 5 4 ,

Ultra-QuickSort produces the output 
0 1 4 5 9 .

Your task is to determine how many swap operations Ultra-QuickSort needs to perform in order to sort a given input sequence.

Input

The input contains several test cases. Every test case begins with a line that contains a single integer n < 500,000 -- the length of the input sequence. Each of the the following n lines contains a single integer 0 ≤ a[i] ≤ 999,999,999, the i-th input sequence element. Input is terminated by a sequence of length n = 0. This sequence must not be processed.

Output

For every input sequence, your program prints a single line containing an integer number op, the minimum number of swap operations necessary to sort the given input sequence.

Sample Input

5
9
1
0
5
4
3
1
2
3
0

Sample Output

6
0

Source


思路:直接写一个归并排序求逆序数的模板就行了,不过这里要注意,使用int会溢出

ac代码

#include <iostream>
using namespace std;

const int maxn=500000+5;
long long  ans=0;
long long  a[maxn],t[maxn];
void mergesort(int x,int y){

    if(x==y) return ;

    else {
        int mid=(x+y)/2;

        int mm=mid+1,xx=x,i=x;
        mergesort(x,mid);
        mergesort(mid+1,y);

        while(xx<=mid && mm<=y){

            if(a[xx]<=a[mm]) t[i++]=a[xx++];
            else {
                ans+=mid-xx+1;
                t[i++]=a[mm++];
            }
        }

        while(xx<=mid) t[i++]=a[xx++];
        while(mm<=y)  t[i++]=a[mm++];

         for(int i=x;i<=y;i++){
            a[i]=t[i];
        }
    }

}
int  main(){

    int n;
    while(cin>>n &&n){

        for(int i=0;i<n;i++){
            cin>>a[i];
        }
        ans=0;
        mergesort(0,n-1);
        cout<<ans<<endl;
    }
    return 0;
}



评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值