Poj 2021 Relative Relatives

Relative Relatives
Time Limit: 1000MS Memory Limit: 30000K
Total Submissions: 3558 Accepted: 1568

Description

Today is Ted's 100th birthday. A few weeks ago, you were selected by the family to contact all of Ted's descendants and organize a surprise party. To make this task easier, you created an age-prioritized list of everyone descended from Ted. Descendants of the same age are listed in dictionary order. 

The only materials you had to aid you were birth certificates. Oddly enough, these birth certificates were not dated. They simply listed the father's name, the child's name, and the father's exact age when the baby was born.

Input

Input to this problem will begin with line containing a single integer n indicating the number of data sets. Each data set will be formatted according to the following description. 

A single data set has 2 components: 
  1. Descendant Count - A line containing a single integer X (where 0 < X < 100) indicating the number of Ted's descendants. 
  2. Birth Certificate List - Data for X birth certificates, with one certificate's data per line. Each certificate's data will be of the format "FNAME CNAME FAGE" where: 
    • FNAME is the father's name. 
    • CNAME is the child's name. 
    • FAGE is the integer age of the father on the date of CNAMEs birth.

Note: 
  • Names are unique identifiers of individuals and contain no embedded white space. 
  • All of Ted's descendants share Ted's birthday. Therefore, the age difference between any two is an integer number of years. (For those of you that are really picky, assume they were all born at the exact same hour, minute, second, etc... of their birth year.) 
  • You have a birth certificate for all of Ted's descendants (a complete collection).

Output

For each data set, there will be X+1 lines of output. The first will read, "DATASET Y", where Y is 1 for the first data set, 2 for the second, etc. The subsequent X lines constitute your age-prioritized list of Ted's descendants along with their ages using the format "NAME AGE". Descendants of the same age will be listed in dictionary order.

Sample Input

2
1
Ted Bill 25
4
Ray James 40
James Beelzebub 17
Ray Mark 75
Ted Ray 20

Sample Output

DATASET 1
Bill 75
DATASET 2
Ray 80
James 40
Beelzebub 23
Mark 5

Source


思路:比较简单的模拟题,直接对,每个对象查找父亲,当父亲是Ted时就可以获取该人的年龄,依次类推
AC代码:
#include <iostream>
#include <cstring>
#include <cstdio>
#include <algorithm>
#include <string>
using namespace std;

const int maxn=100+5;

struct people{
    int age,year;
    string fname,name;
}x[maxn];

bool cmp(people a,people b){

    if(a.age==b.age)
        return a.name<b.name;
    return a.age>b.age;
}
int main(){

    int t;
    cin>>t;
    for(int j=1;j<=t;j++){
        int n;
        cin>>n;
        for(int i=0;i<n;i++){
            x[i].age=0;
            cin>>x[i].fname>>x[i].name>>x[i].year;
            if(x[i].fname=="Ted")
            x[i].age=100-x[i].year;
        }

        for(int i=0;i<n;i++){
                string fs=x[i].fname;
            for(int j=0;j<n;j++){
                if(x[j].name==fs && x[j].age!=0){
                    x[i].age=x[j].age-x[i].year;
                    break;
                }
            }
        }
        sort(x,x+n,cmp);
        cout<<"DATASET "<<j<<endl;
        for(int i=0;i<n;i++)
            cout<<x[i].name<<" "<<x[i].age<<endl;
    }
    return 0;
}


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值