Poj 2153 Rank List

Rank List
Time Limit: 10000MS Memory Limit: 65536K
Total Submissions: 10206 Accepted: 3450

Description

Li Ming is a good student. He always asks the teacher about his rank in his class after every exam, which makes the teacher very tired. So the teacher gives him the scores of all the student in his class and asked him to get his rank by himself. However, he has so many classmates, and he can’t know his rank easily. So he tends to you for help, can you help him?

Input

The first line of the input contains an integer N (1 <= N <= 10000), which represents the number of student in Li Ming’s class. Then come N lines. Each line contains a name, which has no more than 30 letters. These names represent all the students in Li Ming’s class and you can assume that the names are different from each other. 

In (N+2)-th line, you'll get an integer M (1 <= M <= 50), which represents the number of exams. The following M parts each represent an exam. Each exam has N lines. In each line, there is a positive integer S, which is no more then 100, and a name P, which must occur in the name list described above. It means that in this exam student P gains S scores. It’s confirmed that all the names in the name list will appear in an exam. 

Output

The output contains M lines. In the i-th line, you should give the rank of Li Ming after the i-th exam. The rank is decided by the total scores. If Li Ming has the same score with others, he will always in front of others in the rank list.

Sample Input

3
Li Ming
A
B
2
49 Li Ming
49 A
48 B
80 A
85 B
83 Li Ming

Sample Output

1
2

Source

POJ Monthly,Li Haoyuan

思路:比较简单的题目,根据总分数排名,并且每次输出排名就行了,不过要注意,分数是总计分,不是单次分数
AC代码:
#include <iostream>
#include <map>
#include <cstring>
#include <cstdio>
#include <string>
using namespace std;

const int maxn=10000+5;

int xx[maxn];
char name[100];
map<string,int> mp;

int main(){

    int n;
    cin>>n;
    cin.get();
    string tmp;
    for(int i=0;i<n;i++){
        gets(name);
        mp[name]=i;
        xx[i]=0;
    }
    int m;
    cin>>m;
    while(m--){
        int sc;
        int ssc;
        for(int i=0;i<n;i++){
            //cin>>xx[i];
            cin>>sc;
            getchar();
            gets(name);
            xx[mp[name]]+=sc;
        }
        int ans=1;
        for(int i=0;i<n;i++){
            if(xx[i]>xx[mp["Li Ming"]])
                ans++;
        }
        cout<<ans<<endl;
    }


    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值