Poj 2406 Power Strings

Power Strings
Time Limit: 3000MS Memory Limit: 65536K
Total Submissions: 40258 Accepted: 16750

Description

Given two strings a and b we define a*b to be their concatenation. For example, if a = "abc" and b = "def" then a*b = "abcdef". If we think of concatenation as multiplication, exponentiation by a non-negative integer is defined in the normal way: a^0 = "" (the empty string) and a^(n+1) = a*(a^n).

Input

Each test case is a line of input representing s, a string of printable characters. The length of s will be at least 1 and will not exceed 1 million characters. A line containing a period follows the last test case.

Output

For each s you should print the largest n such that s = a^n for some string a.

Sample Input

abcd
aaaa
ababab
.

Sample Output

1
4
3

Hint

This problem has huge input, use scanf instead of cin to avoid time limit exceed.

Source


   思路:简单题目,KMP算法的基本应用,要理解好len-next[len]的含义,对于next来说  k=tmp-next[tmp],则k代表的是第tmp个字符匹配失败是回溯的长度,也就是tmp之前的串的前缀长度,如果该串是循环串的话,那么该串的len-next[len]所代表的含义就是整个串的公共串的长度,假如len%该长度==0,也就是说公共串是该串的子串,也就是循环的子串。

AC代码如下:

#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int maxn=10000000+5;
int next[maxn];
char tmp[maxn];

void getNext(int len){

    memset(next,0,sizeof(next));
    next[0]=-1;
    int i=0,j=-1;
    while(i<len){
        if(j==-1 || tmp[i]==tmp[j]){
            i++;
            j++;
            next[i]=j;
        }
        else j=next[j];
    }
}

int main(){

    while(scanf("%s",tmp)==1){
        if(tmp[0]=='.') break;
        int len=strlen(tmp);
        getNext(len);
        if(len%(len-next[len])==0){
            printf("%d\n",len/(len-next[len]));
        }
        else printf("1\n");
    }

    return 0;
}




  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值