Hdu 2846 Repository 字典树应用+变形

Repository

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/65536 K (Java/Others)
Total Submission(s): 3730    Accepted Submission(s): 1363


Problem Description
When you go shopping, you can search in repository for avalible merchandises by the computers and internet. First you give the search system a name about something, then the system responds with the results. Now you are given a lot merchandise names in repository and some queries, and required to simulate the process.
 

Input
There is only one case. First there is an integer P (1<=P<=10000)representing the number of the merchanidse names in the repository. The next P lines each contain a string (it's length isn't beyond 20,and all the letters are lowercase).Then there is an integer Q(1<=Q<=100000) representing the number of the queries. The next Q lines each contains a string(the same limitation as foregoing descriptions) as the searching condition.
 

Output
For each query, you just output the number of the merchandises, whose names contain the search string as their substrings.
 

Sample Input
  
  
20 ad ae af ag ah ai aj ak al ads add ade adf adg adh adi adj adk adl aes 5 b a d ad s
 

Sample Output
  
  
0 20 11 11 2
 

Source
 
      思路:简单题目,字典树的简单应用+变形,由于查找的是子串而不是前缀,所以插入的时候要将全部的子串都插入,不过会出现同一个串有多个相同的子串,所以在节点上加一个标记,标记是否为当前串就行了,
     AC代码如下:
#include <iostream>
#include <cstring>
#include <cstdio>
using namespace std;
const int seg_size=26;

struct Node{
    Node *next[seg_size];
    int cnt;
    int id;
    Node(){
        memset(next,NULL,sizeof(next));
        cnt=0;id=-1;
    }
} * root;

Node * getNode(){
    Node *tmp=new Node();
    return tmp;
}

void Insert(char *p,int iid){

    Node * tmp=root;
    while(*p){
        int id=*p-'a';
        if(tmp->next[id]==NULL){
            tmp->next[id]=getNode();
        }
        tmp=tmp->next[id];
        p++;
        if(tmp->id!=iid){
          (tmp->cnt)++;
        }
        tmp->id=iid;
    }
}

int Search(char *p){

    Node *tmp=root;
    while(*p){
        int id=*p-'a';
        if(tmp->next[id]!=NULL){
            tmp=tmp->next[id];
            p++;
        }
        else return 0;
    }
    return tmp->cnt;
}

int main(){

    int n;
    char tmp[25];
    root=getNode();
    scanf("%d",&n);
    while(n--){
        scanf("%s",tmp);
        int len=strlen(tmp);
        for(int i=0;i<len;i++)
          Insert(tmp+i,n+1);
    }
    scanf("%d",&n);
    while(n--){
        scanf("%s",tmp);
        printf("%d\n",Search(tmp));
    }

    return 0;
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值