HDU4135容斥原理递归与非递归版

Co-prime

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 1207    Accepted Submission(s): 440


Problem Description
Given a number N, you are asked to count the number of integers between A and B inclusive which are relatively prime to N.
Two integers are said to be co-prime or relatively prime if they have no common positive divisors other than 1 or, equivalently, if their greatest common divisor is 1. The number 1 is relatively prime to every integer.
 

Input
The first line on input contains T (0 < T <= 100) the number of test cases, each of the next T lines contains three integers A, B, N where (1 <= A <= B <= 10 15) and (1 <=N <= 10 9).
 

Output
For each test case, print the number of integers between A and B inclusive which are relatively prime to N. Follow the output format below.
 

Sample Input
  
  
2 1 10 2 3 15 5
 

Sample Output
  
  
Case #1: 5 Case #2: 10
Hint
In the first test case, the five integers in range [1,10] which are relatively prime to 2 are {1,3,5,7,9}.
 

Source
 
非递归版
#define DeBUG
#include <iostream>
#include <cstdio>
#include <cstring>
#include <cmath>
#include <cstdlib>
#include <algorithm>
#include <vector>
#include <stack>
#include <queue>
#include <string>
#include <set>
#include <sstream>
#include <map>
#include <bitset>
using namespace std ;
#define zero {0}
#define INF 0x3f3f3f3f
#define EPS 1e-6
typedef long long LL;
const double PI = acos(-1.0);
//#pragma comment(linker, "/STACK:102400000,102400000")
inline int sgn(double x)
{
    return fabs(x) < EPS ? 0 : (x < 0 ? -1 : 1);
}
#define N 100005
std::vector<int> vt;
long long n, a, b, res;
long long que[10240];
void fx()//提取因子
{
    vt.clear();
    res = n;
    for (int i = 2; i * i <= n; i++)
    {
        if (res % i == 0)
        {
            vt.push_back(i);
            while (res % i == 0)
            {
                res /= i;
            }
        }
    }
    if (res > 1)vt.push_back(res);
}
//比如求1~30 内与30互质的
//30-30/2-30/3+30/6-30/5+30/10+30/15-30/30
//que数组里就是 1,-2,-3,6,-5,10,15,-30
long long cal(long long n, long long t)
{
    int num = 0;
    que[num++] = 1;
    for (int i = 0; i < vt.size(); i++)
    {
        int ep = vt[i];
        int k = num;
        for (int j = 0; j < k; j++)
            que[num++] = ep * que[j] * (-1);
    }
    long long sum = 0;
    for (int i = 0; i < num; i++)
        sum += t / que[i];
    return sum;
}
int main()
{
#ifdef DeBUGs
    freopen("C:\\Users\\Sky\\Desktop\\1.in", "r", stdin);
#endif
    int T, tcase = 0;
    cin >> T;
    while (T--)
    {
        cin >> a >> b >> n;
        fx();
        long long ans = cal(n, b) - cal(n, a - 1);
        printf("Case #%d: %I64d\n", ++tcase, ans);
    }

    return 0;
}

递归版,转自 http://blog.csdn.net/dellaserss/article/details/8239952
不贴了。。。
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值