【算法笔记4.4小节-贪心】问题 E: FatMouse's Trade

题目链接:http://codeup.cn/problem.php?cid=100000584&pid=4

题目描述

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

输入

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

 

输出

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

样例输入

4 2
4 7
1 3
5 5
4 8
3 8
1 2
2 5
2 4
-1 -1

样例输出

2.286
2.500

思路

1. 输入的同时记录每单位F对应多少的J,并按照J从大到小排序。

2. 遍历每个房间,若当前的m大于等于当前房间的F[i],则对换,否则,按照比例对换。

/*
FatMouse有M吨的猫粮,去交换JavaBean
N个房间
J[i]  F[i]//J[i]吨的JavaBean对应F[I]吨的猫粮
*/


#include<stdio.h>
#include<math.h>
#include<algorithm>
using namespace std;
struct Trade{
    int j;
    int f;
    double sprice;//1单位F对应的J数
}trade[1010];
bool cmp(Trade a, Trade b){
    if(a.sprice>b.sprice) return true;
    return false;
}
int main()
{
    int m ,n;
    while(scanf("%d%d",&m,&n),m!=-1&&n!=-1)
    {
        for(int i=0;i<n; i++)
        {
            scanf("%d%d",&trade[i].j,&trade[i].f);
            trade[i].sprice = trade[i].j*1.0/trade[i].f;
        }
        sort(trade, trade+n,cmp);
        double sum=0;
        for(int i=0; i<n; i++)
        {
            if(m >= trade[i].f)//当前的m > f,全换
            {
                sum = sum + trade[i].j;
                m = m - trade[i].f;
            }
            else
            {
                sum = sum + trade[i].sprice*m;
                break;
            }
        }

        printf("%.3f\n", sum);

    }
    return 0;
}

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

 

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值