题 E: FatMouse's Trade

题目描述

FatMouse prepared M pounds of cat food, ready to trade with the cats guarding the warehouse containing his favorite food, JavaBean.
The warehouse has N rooms. The i-th room contains J[i] pounds of JavaBeans and requires F[i] pounds of cat food. FatMouse does not have to trade for all the JavaBeans in the room, instead, he may get J[i]* a% pounds of JavaBeans if he pays F[i]* a% pounds of cat food. Here a is a real number. Now he is assigning this homework to you: tell him the maximum amount of JavaBeans he can obtain.

 

输入

The input consists of multiple test cases. Each test case begins with a line containing two non-negative integers M and N. Then N lines follow, each contains two non-negative integers J[i] and F[i] respectively. The last test case is followed by two -1's. All integers are not greater than 1000.

 

输出

For each test case, print in a single line a real number accurate up to 3 decimal places, which is the maximum amount of JavaBeans that FatMouse can obtain.

 

样例输入

4 2
4 7
1 3
5 5
4 8
3 8
1 2
2 5
2 4
-1 -1

样例输出

2.286
2.500

 

#include <stdio.h>
#include <algorithm>
using namespace std;
struct warehouse{
	int  bean,catfood;
	double percent;
}ware[1001];
bool cmp(warehouse a,warehouse b){
	return a.percent >b.percent ;
}
int main(){
	int i,m,n;
	while(scanf("%d%d",&m,&n)) {
		if(m==-1&&n==-1)	break;
		for(i=0;i<n;i++){
			scanf("%d%d",&ware[i].bean ,&ware[i].catfood );
			ware[i].percent =1.0*ware[i].bean/ware[i].catfood;
		}
		sort(ware,ware+n,cmp);
		double obtain=0;
		for(i=0;m;i++){
			if(ware[i].catfood <m){
				obtain+=ware[i].bean ;
				m-=ware[i].catfood ;
			}
			else{
				obtain+=1.0*m/ware[i].catfood *ware[i].bean ;
				m=0;
			}
		}
		printf("%.3f\n",obtain);
	}
	return 0;
}

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 打赏
    打赏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包

打赏作者

Mr_Zhangmc

你的鼓励将是我创作的最大动力

¥1 ¥2 ¥4 ¥6 ¥10 ¥20
扫码支付:¥1
获取中
扫码支付

您的余额不足,请更换扫码支付或充值

打赏作者

实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值