hdu 1856 More is better

Problem Description
Mr Wang wants some boys to help him with a project. Because the project is rather complex, the more boys come, the better it will be. Of course there are certain requirements.

Mr Wang selected a room big enough to hold the boys. The boy who are not been chosen has to leave the room immediately. There are 10000000 boys in the room numbered from 1 to 10000000 at the very beginning. After Mr Wang’s selection any two of them who are still in this room should be friends (direct or indirect), or there is only one boy left. Given all the direct friend-pairs, you should decide the best way.

Input
The first line of the input contains an integer n (0 ≤ n ≤ 100 000) - the number of direct friend-pairs. The following n lines each contains a pair of numbers A and B separated by a single space that suggests A and B are direct friends. (A ≠ B, 1 ≤ A, B ≤ 10000000)

Output
The output in one line contains exactly one integer equals to the maximum number of boys Mr Wang may keep.

Sample Input
4
1 2
3 4
5 6
1 6
4
1 2
3 4
5 6
7 8

Sample Output
4
2

找一个节点数量最多的联通区域,并输出最大的数量。并查集建立连接,map映射父节点到节点的个数

#include<bits/stdc++.h>
using namespace std;

const int maxn = 100007;
int fa[maxn];
int find(int x)//压缩路径的非递归写法,数量量较大时才用
{
	int r = x;//储存临时变量
	while(fa[r]!=r)r = fa[r];//找到父节点
	int i = x, j;
	while(i!=r)
	{
		j = fa[i];//储存临时变量
		fa[i] = r;//把路径上的指向父节点
		i = j;
	}
	return r;//返回父节点
}
int main()
{
	//freopen("11.txt", "r", stdin);
	int t,a,b;
	map<int, int> mp;//父节点到连通块人数的映射
	while(cin >> t)
	{
		mp.clear();
		for (int i = 1;i<=maxn;i++)
			fa[i] = i;

		for (int i = 0; i < t; i++)
		{
			cin >> a >> b;
			int x = find(a), y = find(b);
            if(x!=y)
				  fa[x]=y;
		}
		int res = 0;
		for (int i = 1;i<=maxn;i++)
		{
			int k = find(i);
			mp[k]++;
		}
		for (map<int, int>::iterator it = mp.begin();it!=mp.end();it++)
		{
			res =max(res,it->second);
		}

		cout << res << endl;
	}

	return 0;
 }
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值