最长递增子序列

Sample Input

4
1 2 2 3

Sample Output

4

代码

#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#define LL long long
using namespace std;

int a[1007];
int len[1007];
int main()
{
    //freopen("in.txt","r",stdin);
    int n,i,j;
    scanf("%d",&n);
    for(i=1;i<=n;i++)
    {
        scanf("%d",&a[i]);
    }
    int cnt=0;
    for(i=1;i<=n;i++)
    {
        int x=lower_bound(len+1,len+1+cnt,a[i])-len;//若为不减序列则用upper_bound
        if(x<=cnt) len[x]=a[i];
        if(x==cnt+1)
        {
            cnt++;
            len[cnt]=a[i];
        }
    }
    printf("%d\n",cnt);
    return 0;
}
  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值