poj1328贪心

Radar Installation
Time Limit: 1000MS Memory Limit: 10000K
Total Submissions: 76566 Accepted: 17139

Description

Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d. 

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates. 
 
Figure A Sample Input of Radar Installations


Input

The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases. 

The input is terminated by a line containing pair of zeros 

Output

For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. "-1" installation means no solution for that case.

Sample Input

3 2
1 2
-3 1
2 1

1 2
0 2

0 0

Sample Output

Case 1: 2
Case 2: 1

///

分析:

1.以d为斜边作直角三角形,可知每个坐标在x轴上形成一个闭区间,在此区间内的雷达满足要求;

2.因此题目转化为求区间的集合数,相交的为一个集合,求最小集合数;

3.贪心规则:由左向右摆放雷达,因此从考虑最靠左的区间右端点开始,向右推进求集合数。

<span style="font-size:14px;">#include <cstdio>
#include <iostream>
#include <algorithm>
#include <cstring>
#include <cmath>
using namespace std;

int n;
int d;
pair<double , double>group[1000];
pair<signed int , signed int>coordinate[1000];
int times = 0;

int main(int argc, char const* argv[])
{
    //freopen("input.txt","r",stdin);
    while (scanf("%d%d",&n,&d)){
        if((n == 0) && (d == 0)) break;
        times++;
        int ans = 1;
        bool out = false;
        if(d < 0){
            out = true;
        }
        for (int i = 0; i < n; i += 1){
            scanf("%d%d",&coordinate[i].first,&coordinate[i].second);
            if (d >= coordinate[i].second){
                double dd = sqrt(d*d-(coordinate[i].second)*(coordinate[i].second));
                group[i].first = coordinate[i].first+dd;//group.right
                group[i].second = coordinate[i].first-dd;//group.left
            }
            else{
                out = true;
            }
        }
        if(out){
            printf("Case %d: -1\n",times);
            continue;
        }
        sort(group,group+n);//depended on right
        int i= 0;
        for (int j = i+1; j < n; j += 1){
            if (group[j].second > group[i].first){
                ans++;
                i = j;
            }
        }
        printf("Case %d: %d\n",times,ans);
    }
    return 0;
}</span>

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值