POJ1328 贪心算法

Radar Installation
Time Limit: 1000MS

Memory Limit: 10000K
Total Submissions: 93202

Accepted: 20809
Description
Assume the coasting is an infinite straight line. Land is in one side of coasting, sea in the other. Each small island is a point locating in the sea side. And any radar installation, locating on the coasting, can only cover d distance, so an island in the sea can be covered by a radius installation, if the distance between them is at most d.

We use Cartesian coordinate system, defining the coasting is the x-axis. The sea side is above x-axis, and the land side below. Given the position of each island in the sea, and given the distance of the coverage of the radar installation, your task is to write a program to find the minimal number of radar installations to cover all the islands. Note that the position of an island is represented by its x-y coordinates.

Figure A Sample Input of Radar Installations

http://poj.org/images/1328_1.jpg
Input
The input consists of several test cases. The first line of each case contains two integers n (1<=n<=1000) and d, where n is the number of islands in the sea and d is the distance of coverage of the radar installation. This is followed by n lines each containing two integers representing the coordinate of the position of each island. Then a blank line follows to separate the cases.

The input is terminated by a line containing pair of zeros
Output
For each test case output one line consisting of the test case number followed by the minimal number of radar installations needed. “-1” installation means no solution for that case.
Sample Input
3 2
1 2
-3 1
2 1

1 2
0 2

0 0
Sample Output
Case 1: 2
Case 2: 1
Source
Beijing 2002

这题用的是贪心算法,不过坑的点不是算法,而是各种条件,比如d>0啥的。
主要是将范围转换成X轴上的线段,如果线段有重叠,那么就可以用一个雷达来监控重叠的两个小岛。

#include<iostream>
#include<algorithm>
#include<cmath>
#define MAX 1005
using namespace std;
int arraylengths;
struct island{
double left;
double right;
};
typedef island* myisland;
island array[1000];
bool compare(island a,island b)
{
return a.right <b.right ;
}
void removeIsland(myisland a,int index)//从数组中删除地址为index的元素 
{
for(int j=index;j<arraylengths-1;j++)
    a[j]=a[j+1];
arraylengths--;
}
void greedy(myisland a)
{
for(int i=1;i<arraylengths;i++)
{
    if(a[0].right>=a[i].left&&a[0].right<=a[i].right)
        {
            removeIsland(a,i);
            i--;//一定要减一,否则直接跳过原来的第二个 
        }
}
removeIsland(a,0);  //每次设置一个即把第一个点删去 
}
int main()
{
int n,d;
int cases=0;
int x,y;
int count=0;
int flag=0;
while(cin>>n>>d)
    {
        if(d<0)
            {
                cout<<"Case "<<++cases<<": "<<-1<<endl; //三个输出是有优先级的 
                flag=1;
            }   
        else if(n==0&&d==0)
            break;
        arraylengths=n;
        for(int i=0;i<n;i++)
        {
            cin>>x>>y;
            if(d>=y)
            {
                array[i].left=x-sqrt(double(d*d-y*y));
                array[i].right=x+sqrt(double(d*d-y*y));
            }//POJ不支持C11,所以sqrt()要指明数据类型
            else if(flag==0)
                {
                    cout<<"Case "<<++cases<<": "<<-1<<endl;     
                    flag=1;
                }
        }
        sort(array,array+n,compare);
        while(arraylengths>0){
            greedy(array);
            count++;
        }
        if(flag==0)
            cout<<"Case "<<++cases<<": "<<count<<endl;  
        count=0;//一定要初始化 
        flag=0;
    }   
}
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值