01背包 poj2184

Cow Exhibition
Time Limit: 1000MS
Memory Limit: 65536K
Total Submissions: 12854
Accepted: 5148
Description
“Fat and docile, big and dumb, they look so stupid, they aren’t much
fun…”
- Cows with Guns by Dana Lyons

The cows want to prove to the public that they are both smart and fun. In order to do this, Bessie has organized an exhibition that will be put on by the cows. She has given each of the N (1 <= N <= 100) cows a thorough interview and determined two values for each cow: the smartness Si (-1000 <= Si <= 1000) of the cow and the funness Fi (-1000 <= Fi <= 1000) of the cow.

Bessie must choose which cows she wants to bring to her exhibition. She believes that the total smartness TS of the group is the sum of the Si’s and, likewise, the total funness TF of the group is the sum of the Fi’s. Bessie wants to maximize the sum of TS and TF, but she also wants both of these values to be non-negative (since she must also show that the cows are well-rounded; a negative TS or TF would ruin this). Help Bessie maximize the sum of TS and TF without letting either of these values become negative.
Input
* Line 1: A single integer N, the number of cows

  • Lines 2..N+1: Two space-separated integers Si and Fi, respectively the smartness and funness for each cow.
    Output
  • Line 1: One integer: the optimal sum of TS and TF such that both TS and TF are non-negative. If no subset of the cows has non-negative TS and non- negative TF, print 0.

Sample Input
5
-5 7
8 -6
6 -3
2 1
-8 -5
Sample Output
8
Hint
OUTPUT DETAILS:

Bessie chooses cows 1, 3, and 4, giving values of TS = -5+6+2 = 3 and TF
= 7-3+1 = 5, so 3+5 = 8. Note that adding cow 2 would improve the value
of TS+TF to 10, but the new value of TF would be negative, so it is not
allowed.

分析一:把其中一个属性值看做value,另一个看做weight,便成了01背包的变形
设dp[j]为前i个cow放入容量为j的背包中所获取的最大weight,可以找到递推公式
dp[j] = max(dp[j]+dp[j-value[i]]+weight[i]);
分析二:在分析一的基础上,可以看成是求填满容量分别为0,1,…..的01背包所获得最大价值中的最大值

注意:本题的重点实在数据范围的考虑和处理上

1.dp数组初始值不能为0,如果初始值为0,可能错误地漏掉dp[j-value[i]]+weight[i]为负值的情况,此处设为-INF;

2.如果dp[j-value[i]]没有被处理,则当weight[i]为负时可能会被错误地舍弃,为了避免这种情况,在dp前加上了if (dp[j-value[i]] > -INF),也可以写成if (dp[j-value[i]] != -INF)

3.dp[j]的横坐标j可能会出现负值,为了避免这种情况,dp时让横坐标右移add个单位,使j一定为>=0的值,此时正序dp有j <= maxS+add且j-value[i] >=0,逆序时有j -value[i] <= maxS+add且j>=0,最后计算结果的时候再减去右移的单位add即可

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
#include <sstream>
#include <set>
#include <functional>
using namespace std;

#define INT_MAX 1 << 30
#define MAX 100
#define INF 0x3f3f3f3f
typedef long long ll;
int n;
int maxS = 100000;              //所有value的和的范围为[-100000,100000];
int add = 100000;               //将dp[j]的下标右移add单位,保证一定大于零
int value[200];
int weight[200];
int dp[200002];                 //下标右移后,范围为0-200000
int ans;

void solve()
{
    for (int i = 0; i < n; i += 1){
        if (value[i] > 0){      //正值逆序,详解参考背包九讲
            for (int j = maxS+add; j >= value[i]; j -= 1){
                dp[j] = max(dp[j],dp[j-value[i]]+weight[i]);
            }
        }
        else{           //负值正序
            for (int j = 0; j <= maxS+add+value[i]; j += 1){
                dp[j] = max(dp[j],dp[j-value[i]]+weight[i]);
            }
        }
    }
    ans = 0;
    for (int i = add; i <= add+maxS; i += 1){  //保证i-add(即下标回归原点时的value值)大于0
        if (dp[i] >= 0){
            ans = max(ans,dp[i]+i-add);
        }
    }
    printf("%d\n",ans);
}

int main(int argc, char const* argv[])
{
    scanf("%d",&n);
    for (int i = 0; i < n; i += 1){
        scanf("%d%d",&value[i],&weight[i]);
    }
    for (int j = 0; j <= maxS+add; j += 1){
        dp[j] = -INF;
    }                          //如果初始值为0,可能错误地漏掉dp[j-value[i]]+weight[i]为负值的情况
    dp[add] = 0;             //背包中什么也不放的时候,值为0
    solve();
    return 0;
}
  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值