poj3104 二分

Drying
Time Limit: 2000MS Memory Limit: 65536K
Total Submissions: 18783 Accepted: 4727

Description

It is very hard to wash and especially to dry clothes in winter. But Jane is a very smart girl. She is not afraid of this boring process. Jane has decided to use a radiator to make drying faster. But the radiator is small, so it can hold only one thing at a time.

Jane wants to perform drying in the minimal possible time. She asked you to write a program that will calculate the minimal time for a given set of clothes.

There are n clothes Jane has just washed. Each of them took ai water during washing. Every minute the amount of water contained in each thing decreases by one (of course, only if the thing is not completely dry yet). When amount of water contained becomes zero the cloth becomes dry and is ready to be packed.

Every minute Jane can select one thing to dry on the radiator. The radiator is very hot, so the amount of water in this thing decreases by k this minute (but not less than zero — if the thing contains less than k water, the resulting amount of water will be zero).

The task is to minimize the total time of drying by means of using the radiator effectively. The drying process ends when all the clothes are dry.

Input

The first line contains a single integer n (1 ≤ n ≤ 100 000). The second line contains ai separated by spaces (1 ≤ ai ≤ 109). The third line contains k (1 ≤ k ≤ 109).

Output

Output a single integer — the minimal possible number of minutes required to dry all clothes.

Sample Input

sample input #1
3
2 3 9
5

sample input #2
3
2 3 6
5

Sample Output

sample output #1
3

sample output #2
2

题意:给出n件衣服晒干所需时间和暖气片功效,求晾干所有衣服最小的时间。

分析:二分时间t,c(x)需要推公式 :

设x为需要熨斗的分钟

x+y = t

x*k+y>=ai

y>=(ai-t)/(k-1),向上取整,y>=(ai-t)/(k-1)或者利用函数ceil()。

ps:一开始没推公式自己就在c(x)中贪心,好麻烦而且还不对。。。太坑了这题。

/*
如果写ub-lb>1,写lb = mid,ub = mid
如果写ub>lb,写lb = mid+1,ub = mid
*/
#include <cstdio>  
#include <cstdlib>  
#include <iostream>  
#include <stack>  
#include <queue>  
#include <algorithm>  
#include <cstring>  
#include <string>  
#include <cmath>  
#include <vector>  
#include <bitset>  
#include <list>  
#include <sstream>  
#include <set>  
#include <map>
#include <functional>  
using namespace std;  
  
#define INF 0x3f3f3f3f  
#define MAXN 1000 
typedef long long ll;  

int n;
int k;
int x[100005];

bool C(int &d)
{
    ll sum = 0;
    for (int i = 0; i < n; ++i){
        if(x[i] <= d) continue;
        sum += (x[i]-d+k-2)/(k-1);
    }
    if(sum <= d) return true;
    else return false;
}

int main()  
{  
    while(scanf("%d",&n)!=EOF){
        for (int i = 0; i < n; ++i) scanf("%d",&x[i]);
        scanf("%d",&k);
        if (k == 1){ printf("%d\n",x[n-1]);continue;}
        int lb = 0,ub = INF;
        while(ub-lb>1){
            int mid = (ub+lb)/2;
            if(C(mid)) ub = mid;
            else lb = mid;
        }
        printf("%d\n",ub);
    }
    return 0;  
}  

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值