poj2785 折半枚举 双向查找

4 Values whose Sum is 0
Time Limit: 15000MS Memory Limit: 228000K
Total Submissions: 24737 Accepted: 7467
Case Time Limit: 5000MS

Description

The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .

Input

The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2 28 ) that belong respectively to A, B, C and D .

Output

For each input file, your program has to write the number quadruplets whose sum is zero.

Sample Input

6
-45 22 42 -16
-41 -27 56 30
-36 53 -37 77
-36 30 -75 -46
26 -38 -10 62
-32 -54 -6 45

Sample Output

5

Hint

Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).

题意:n组有a,b,c,d四个元素的数据,每组取出一个,使和为0,求组合数。

解法一:枚举c[i]+d[j],然后对于a[i]+b[j]的每个组合,查找在c[i]+d[j]中的匹配次数。

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
#include <sstream>
#include <set>
#include <functional>
using namespace std;

#define INF 0x3f3f3f3f
#define MAX 100
typedef long long ll;
int n;
int a[4005],b[4005],c[4005],d[4005];
int y[16000005];

int main(int argc, char const *argv[])
{
	while(scanf("%d",&n)!=EOF) {
		for (int i = 0; i < n; ++i) scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
		for (int i = 0; i < n; ++i)
			for (int j = 0; j < n; ++j)
				y[i*n+j] = c[i]+d[j];
		sort(y,y+n*n);
		ll sum = 0;
		for (int i = 0; i < n; ++i){
			for (int j = 0; j < n; ++j){
				int tmp = -a[i]-b[j];
				sum += upper_bound(y,y+n*n,tmp)-lower_bound(y,y+n*n,tmp);
			}
		}
		printf("%lld\n", sum);	
	}
}

解法二:一的改进,枚举y=c[i]+d[j]和z=a[i]+b[j]然后在数组y中二分查找z的每个值。

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
#include <sstream>
#include <set>
#include <functional>
using namespace std;

typedef long long ll;
int n;
int a[4005],b[4005],c[4005],d[4005];
int y[16000005];
int z[16000005];

int main(int argc, char const *argv[])
{
	scanf("%d",&n);
	for (int i = 0; i < n; ++i) scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
	for (int i = 0; i < n; ++i){
		for (int j = 0; j < n; ++j){
			y[i*n+j] = c[i]+d[j];
			z[i*n+j] = -a[i]-b[j];
		}
	}
	sort(y,y+n*n);
	sort(z,z+n*n);
	ll sum = 0;
	for (int i = 0; i < n*n; ++i)
		sum += upper_bound(y,y+n*n,z[i])-lower_bound(y,y+n*n,z[i]);
	printf("%lld\n", sum);
}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值