4 Values whose Sum is 0
Time Limit: 15000MS | Memory Limit: 228000K | |
Total Submissions:25573 | Accepted: 7680 | |
Case Time Limit: 5000MS |
Description
The SUM problem can be formulated as follows: given four lists A, B, C, D of integer values, compute how many quadruplet (a, b, c, d ) ∈ A x B x C x D are such that a + b + c + d = 0 . In the following, we assume that all lists have the same size n .
Input
The first line of the input file contains the size of the lists n (this value can be as large as 4000). We then have n lines containing four integer values (with absolute value as large as 2
28 ) that belong respectively to A, B, C and D .
Output
For each input file, your program has to write the number quadruplets whose sum is zero.
Sample Input
6 -45 22 42 -16 -41 -27 56 30 -36 53 -37 77 -36 30 -75 -46 26 -38 -10 62 -32 -54 -6 45
Sample Output
5
Hint
Sample Explanation: Indeed, the sum of the five following quadruplets is zero: (-45, -27, 42, 30), (26, 30, -10, -46), (-32, 22, 56, -46),(-32, 30, -75, 77), (-32, -54, 56, 30).
先计算a+b和c+d。然后对于每个a+b二分找出是否有匹配的c+d
代码:
#include<cstdio>
#include<algorithm>
using namespace std;
int a[4004],b[4004],c[4004],d[4004];
int x[16000004],y[16000004];
int main()
{
int n;
while(~scanf("%d",&n))
{
int i,j,st=0;
for(i=0; i<n; i++)
scanf("%d%d%d%d",&a[i],&b[i],&c[i],&d[i]);
for(i=0; i<n; i++)
{
for(j=0; j<n; j++)
{
x[st]=a[i]+b[j];
y[st++]=c[i]+d[j];
}
}
sort(x,x+st);
sort(y,y+st);
y[st]=2*1e9;
long long ans=0;
for(i=0; i<st; i++)
{
int r=-x[i];
int id=lower_bound(y,y+st+1,r)-y;
while(y[id]==r)
{
ans++;
id++;//开始忘了考虑,对于每个x可能有多个匹配的y
}
}
printf("%lld\n",ans);
}
return 0;
}