单调队列--poj2823 从入门到放弃

Sliding Window
Time Limit: 12000MS Memory Limit: 65536K
Total Submissions: 64041 Accepted: 18262
Case Time Limit: 5000MS

Description

An array of size  n ≤ 10 6 is given to you. There is a sliding window of size  k which is moving from the very left of the array to the very right. You can only see the  k numbers in the window. Each time the sliding window moves rightwards by one position. Following is an example: 
The array is  [1 3 -1 -3 5 3 6 7], and  k is 3.
Window positionMinimum valueMaximum value
[1  3  -1] -3  5  3  6  7 -13
 1 [3  -1  -3] 5  3  6  7 -33
 1  3 [-1  -3  5] 3  6  7 -35
 1  3  -1 [-3  5  3] 6  7 -35
 1  3  -1  -3 [5  3  6] 7 36
 1  3  -1  -3  5 [3  6  7]37

Your task is to determine the maximum and minimum values in the sliding window at each position. 

Input

The input consists of two lines. The first line contains two integers  n and  k which are the lengths of the array and the sliding window. There are  n integers in the second line. 

Output

There are two lines in the output. The first line gives the minimum values in the window at each position, from left to right, respectively. The second line gives the maximum values. 

Sample Input

8 3
1 3 -1 -3 5 3 6 7

Sample Output

-1 -3 -3 -3 3 3
3 3 5 5 6 7

题意:给n个数,长度为k的窗口以此右移,求每个窗口中的最大值和最小值。

分析:单调队列,也是醉了,之前根本没听说过。从网上浏览众大神的分析后,学会了一点皮毛。在这里记录下自己的理解。

单调队列思考:
对于一个单调递增队列,每次从队尾插值,从队头取值。//这题不仅数值单调递增,时间(下标)也单调递增。
队尾维护当前状态最大值,所以插值的时候把队列中较大的值踢掉,这些值已经过时,随便删没问题。
队头维护当前状态最小值,所以查找的时候需要往右找到第一个符合条件的值。

#include <cstdio>
#include <cstdlib>
#include <iostream>
#include <stack>
#include <queue>
#include <algorithm>
#include <cstring>
#include <string>
#include <cmath>
#include <vector>
#include <bitset>
#include <list>
#include <sstream>
#include <set>
#include <functional>
using namespace std;

#define maxn 1000001
int n,k;
int a[maxn],ans[maxn],t[maxn];
int front,rear;

void get(int flag)
{
	front = rear = 0;
	//先把前面k-1个放入栈中
	for (int i = 0; i < k-1; ++i){
		while(rear>front && ((!flag && a[i]<ans[rear-1])||(flag && a[i] > ans[rear-1]))) rear--;
		ans[rear] = a[i];
		t[rear++] = i;
		while(t[front] <= i-k) front++;
	}
	//从第一个框开始判断
	for (int i = k-1; i < n; ++i){
		while(rear>front && ((!flag && a[i]<ans[rear-1])||(flag && a[i] > ans[rear-1]))) rear--;//队尾插值
		ans[rear] = a[i];
		t[rear++] = i;
		while(t[front] <= i-k) front++;//队头取值
		printf("%d ",ans[front],i == n-1?'\n':' ');
	}
}

int main(int argc, char const *argv[])
{
	scanf("%d%d",&n,&k);
	for (int i = 0; i < n; ++i) scanf("%d",&a[i]);
	get(0);//单调递增队列,维护对头最小值
	get(1);//单调递减队列,维护对头最大值
}


  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论

“相关推荐”对你有帮助么?

  • 非常没帮助
  • 没帮助
  • 一般
  • 有帮助
  • 非常有帮助
提交
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值