hdu1010(dfs+奇偶剪枝)

99 篇文章 2 订阅

Tempter of the Bone

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 65536/32768 K (Java/Others)
Total Submission(s): 115519    Accepted Submission(s): 31364


Problem Description
The doggie found a bone in an ancient maze, which fascinated him a lot. However, when he picked it up, the maze began to shake, and the doggie could feel the ground sinking. He realized that the bone was a trap, and he tried desperately to get out of this maze.

The maze was a rectangle with sizes N by M. There was a door in the maze. At the beginning, the door was closed and it would open at the T-th second for a short period of time (less than 1 second). Therefore the doggie had to arrive at the door on exactly the T-th second. In every second, he could move one block to one of the upper, lower, left and right neighboring blocks. Once he entered a block, the ground of this block would start to sink and disappear in the next second. He could not stay at one block for more than one second, nor could he move into a visited block. Can the poor doggie survive? Please help him.
 

Input
The input consists of multiple test cases. The first line of each test case contains three integers N, M, and T (1 < N, M < 7; 0 < T < 50), which denote the sizes of the maze and the time at which the door will open, respectively. The next N lines give the maze layout, with each line containing M characters. A character is one of the following:

'X': a block of wall, which the doggie cannot enter; 
'S': the start point of the doggie; 
'D': the Door; or
'.': an empty block.

The input is terminated with three 0's. This test case is not to be processed.
 

Output
For each test case, print in one line "YES" if the doggie can survive, or "NO" otherwise.
 

Sample Input
 
 
4 4 5 S.X. ..X. ..XD .... 3 4 5 S.X. ..X. ...D 0 0 0
 

Sample Output
 
 
NO YES
 

Author
ZHANG, Zheng
 

Source



下午花半个多小时写这题,测试基本都正确,中规中矩的一道dfs,然后坑爹的是!之后就一直超时!!
好吧由于只是新手,对剪枝的各种方法了解甚少,这题在这里采用的是奇偶剪枝,是在参考别人的代码之后才知道的,几经修改了AC
dfs之路任重而道远啊!

说说解题思路,输入一个迷宫,从S走到D的步数给定,(注意 是一定要刚好这个步数才能说是YES),然后就是dfs模板啦套进去,判断是否出界,以及用一个flag变量判断是否达到目标,注意!这里又有一个要点
if(t==bu&&x==xm&&y==ym) {
flag=1;
                return;
}
这样写绝逼会超时!!因为return 之后x,y变了条件就不满足了!所以后面都是无用功!!!!就算奇偶剪枝也过不了的!!!吸取教训

然后就是谈谈奇偶剪枝



来自杭电的课件,非常有用的一个剪枝方法!用了它就AC了,学习一个!

好啦 贴上AC代码 以后有空回来好好品读一下
#include<bits/stdc++.h>
using namespace std;
 int n,m,bu;
 int xq,yq,xm,ym;
 int i,j,kk;
 int cnt,flag;
 int zou[4][2]={0,1,1,0,0,-1,-1,0};
 char map1[10][10];
void dfs(int x,int y,int t){
	if(x>=n||y>=m||x<0||y<0) return ;
	if(t==bu&&x==xm&&y==ym) {
		flag=1;
	}
	if(flag) return;
	if(((bu-t)%2 != (abs(x-xm) + abs(y-ym)) %2)) return;
	if(bu-t-abs(x-xm)-abs(y-ym)<0) return;
	for(int k=0;k<4;k++){
		int x2=x+zou[k][0];
		int y2=y+zou[k][1];
		
		if(map1[x2][y2]!='X'){
			map1[x2][y2]='X';
			dfs(x2,y2,t+1);
			map1[x2][y2]='.';
		}
	}
	return ;
}
int main(){
	
    while(scanf("%d%d%d",&n,&m,&bu)){
    	int wall=0;
    	if(n==0||m==0||bu==0) break;
          getchar();
    	for(i=0;i<n;i++)
    	for(j=0;j<m;j++){
    		scanf(" %c",&map1[i][j]);
    		if(map1[i][j]=='S'){
    			xq=i;yq=j;
			}
			if(map1[i][j]=='D'){
				xm=i;
				ym=j;
			}
			if(map1[i][j]=='X') wall++;
		} 
		flag=0;
		cnt=0;
		
		map1[xq][yq]='X';
		if(n*m-wall-1>=bu) dfs(xq,yq,0);
    	if(flag) cout<<"YES"<<endl;
    	else cout<<"NO"<<endl;
	}

}



  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值