hdu2802(数学题)

99 篇文章 2 订阅

F(N)

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 4904    Accepted Submission(s): 1735


Problem Description

Giving the N, can you tell me the answer of F(N)?
 

Input
Each test case contains a single integer N(1<=N<=10^9). The input is terminated by a set starting with N = 0. This set should not be processed.
 

Output
For each test case, output on a line the value of the F(N)%2009.
 

Sample Input
 
 
1 2 3 0
 

Sample Output
 
 
1 7 20
 

Source



打个表,找找规律。。。4018一次循环
#include<stdio.h>
int f[6000];
int main()
{   f[1]=1;
    f[2]=7;
    for(int i=3;i<4020;i++)
    {
        f[i]=f[i-2]+3*i*i-3*i+1;
        f[i]%=2009;
    }
    int n;
    while(scanf("%d",&n),n)
    {
        printf("%d\n",f[n%4018]);
    }
}



  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值