hdu3280(不是区间DP的解法 很好理解)

99 篇文章 2 订阅

Equal Sum Partitions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 691    Accepted Submission(s): 491


Problem Description
An  equal sum partition of a sequence of numbers is a grouping of the numbers (in the same order as the original sequence) in such a way that each group has the same sum. For example, the sequence:
2 5 1 3 3 7
may be grouped as:
(2 5) (1 3 3) (7)
to yield an equal sum of  7.

Note: The partition that puts all the numbers in a single group is an equal sum partition with the sum equal to the sum of all the numbers in the sequence.

For this problem, you will write a program that takes as input a sequence of positive integers and returns the smallest sum for an equal sum partition of the sequence.
 

Input
The first line of input contains a single integer  P, (1 ≤  P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by a decimal integer  M, (1 ≤  M ≤ 10000), giving the total number of integers in the sequence. The remaining line(s) in the dataset consist of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.
 

Output
For each data set, generate one line of output with the following values: The data set number as a decimal integer, a space, and the smallest sum for an equal sum partition of the sequence.
 

Sample Input
 
 
3 1 6 2 5 1 3 3 7 2 6 1 2 3 4 5 6 3 20 1 1 2 1 1 2 1 1 2 1 1 2 1 1 2 1 1 2 1 1
 

Sample Output
 
 
1 7 2 21 3 2
 

Source
 

Recommend
zhuweicong

今天训练赛的一道题,队友写完发现测试数据错误后就有事走了,等到中午的时候发现只要加一行代码。。就可以过了,有点小可惜~~
 

#include<iostream>
#include<cstring>
#include<algorithm>
using namespace std;
long long m[10005];
int main(){
	int t;cin>>t;
	for(int xu=1;xu<=t;xu++){
		int tmp;cin>>tmp;
		int n;cin>>n;
		long long sum=0;
		for(int i=0;i<n;i++){
			scanf("%lld",&m[i]);
			sum+=m[i];
		}
		long long tsum=0;
		long long fsum=0;
		bool xun1=false;
		for(int i=1;i<=sum;i++){
			if(sum%i==0){
				int j;
				for(j=0;j<n;j++){
				
					tsum+=m[j];
					if(tsum>i){
						tsum=0;
						break;
					}
					else if(tsum==i){
						tsum=0;
					}
					else continue;
					
				}
				if(n==j){
					fsum=i;
					xun1=true;
				}
			}
			if(xun1)break;
		}
		printf("%d %lld\n",xu,fsum);
	}	
	
	return 0;
}


  • 0
    点赞
  • 1
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值