HDU-3280---Equal Sum Partitions (暴力)

Equal Sum Partitions

Time Limit: 2000/1000 MS (Java/Others)    Memory Limit: 32768/32768 K (Java/Others)
Total Submission(s): 720    Accepted Submission(s): 512



Problem Description
An equal sum partition of a sequence of numbers is a grouping of the numbers (in the same order as the original sequence) in such a way that each group has the same sum. For example, the sequence:
2 5 1 3 3 7
may be grouped as:
(2 5) (1 3 3) (7)
to yield an equal sum of 7.

Note: The partition that puts all the numbers in a single group is an equal sum partition with the sum equal to the sum of all the numbers in the sequence.

For this problem, you will write a program that takes as input a sequence of positive integers and returns the smallest sum for an equal sum partition of the sequence.
 

Input
The first line of input contains a single integer P, (1 ≤ P ≤ 1000), which is the number of data sets that follow. The first line of each data set contains the data set number, followed by a space, followed by a decimal integer M, (1 ≤ M ≤ 10000), giving the total number of integers in the sequence. The remaining line(s) in the dataset consist of the values, 10 per line, separated by a single space. The last line in the dataset may contain less than 10 values.
 

Output
For each data set, generate one line of output with the following values: The data set number as a decimal integer, a space, and the smallest sum for an equal sum partition of the sequence.
 

Sample Input
  
  
3 1 6 2 5 1 3 3 7 2 6 1 2 3 4 5 6 3 20 1 1 2 1 1 2 1 1 2 1 1 2 1 1 2 1 1 2 1 1
 

Sample Output
  
  
1 7 2 21 3 2
 
Source
 

题意:给一串数字,问能否把这些数字分成连续的几个区间,并且每部分和相等,输出最小的区间和;

思路:直接暴力,算出所有的数字的和sum,枚举1~sum,第一个符合条件的值便是答案。

AC代码:

 #include<iostream>
 #include<cstdio>
 #include<cstring>
 #include<algorithm>
 using namespace std;
 int t,cas,n,a[10005];
 int main()
 {
     scanf("%d",&t);
     while(t--)
     {
         scanf("%d%d",&cas,&n);
         int sum=0,ans;
         for(int i=1;i<=n;i++)
         {
             scanf("%d",&a[i]);
             sum+=a[i];
         }
         int s,flag;
         for(int i=1;i<=sum;i++)
         {
             if(sum%i==0)
             {
                 s=0,flag=1;
                 for(int j=1;j<=n;j++)
                 {
                     s+=a[j];
                     if(s==i)s=0;
                     if(s>i){flag=0;break;}
                 }
             }
             if(flag){ans=i;break;}
         }
         printf("%d %d\n",cas,ans);
     }
     return 0;
 }


评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值