2017青岛网赛 C - The Dominator of Strings

1

Here you have a set of strings. A dominator is a string of the set dominating all strings else. The string  S S is dominated by  T T if  S S is a substring of  T T.
Input
The input contains several test cases and the first line provides the total number of cases. 
For each test case, the first line contains an integer  N N indicating the size of the set. 
Each of the following  N N lines describes a string of the set in lowercase. 
The total length of strings in each case has the limit of  100000
The limit is 30MB for the input file.
Output
For each test case, output a dominator if exist, or No if not.
Sample Input
3
10
you
better
worse
richer
poorer
sickness
health
death
faithfulness
youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness
5
abc
cde
abcde
abcde
bcde
3
aaaaa
aaaab
aaaac
Sample Output
youbemyweddedwifebetterworsericherpoorersicknesshealthtilldeathdouspartandpledgeyoumyfaithfulness
abcde
No

题目大意: 给你 n 个字符串,让你输出其中一个字符串,这个字符串包含所有其他的字符串。如果没有,输出 No ;

字符串的长度小于100000,个数 n 没有范围,但输入的总量 不超过 30Mb。

思路:由于n不确定,所以可以用vector 来存放字符串。(set也可以,但是由于他会在容器中排序,所以时间会多一点)。


代码:

#include<iostream>
#include<cstdio>
#include<cstring>
#include<algorithm>
#include<vector>
using namespace std;
vector<string> st;

int main ()
{
	std::cin.sync_with_stdio(false);
	int T;
	cin>>T;
	while(T--)
	{
		int n,i,mxlen=-1,bj=0;
		string mx;
		st.clear();
		cin>>n;
		for(i=0;i<n;i++)
		{
			string s;
			cin>>s;
			st.push_back(s);
		}
		for(vector<string>::iterator it=st.begin();it!=st.end();it++)
		{
			int tmp;
			tmp=(*it).length();
			if(tmp>mxlen)
			{
				mxlen=tmp;
				mx=*it;
			}
		}	
		for(vector<string>::iterator it=st.begin();it!=st.end();it++)
		{
			int tmp,j,k;
			tmp=(*it).length();
			if(tmp==mxlen)
			{
				if(*it!=mx)
				{
					bj++;
				}
			}
			if(mx.find(*it)==string::npos)
				bj++;
			if(bj!=0)
			{
				cout<<"No"<<endl;
				break;
			}
		}
		if(bj==0)
			cout<<mx<<endl;
	}
	return 0;
}


  • 1
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
智慧校园整体解决方案是响应国家教育信息化政策,结合教育改革和技术创新的产物。该方案以物联网、大数据、人工智能和移动互联技术为基础,旨在打造一个安全、高效、互动且环保的教育环境。方案强调从数字化校园向智慧校园的转变,通过自动数据采集、智能分析和按需服务,实现校园业务的智能化管理。 方案的总体设计原则包括应用至上、分层设计和互联互通,确保系统能够满足不同用户角色的需求,并实现数据和资源的整合与共享。框架设计涵盖了校园安全、管理、教学、环境等多个方面,构建了一个全面的校园应用生态系统。这包括智慧安全系统、校园身份识别、智能排课及选课系统、智慧学习系统、精品录播教室方案等,以支持个性化学习和教学评估。 建设内容突出了智慧安全和智慧管理的重要性。智慧安全管理通过分布式录播系统和紧急预案一键启动功能,增强校园安全预警和事件响应能力。智慧管理系统则利用物联网技术,实现人员和设备的智能管理,提高校园运营效率。 智慧教学部分,方案提供了智慧学习系统和精品录播教室方案,支持专业级学习硬件和智能化网络管理,促进个性化学习和教学资源的高效利用。同时,教学质量评估中心和资源应用平台的建设,旨在提升教学评估的科学性和教育资源的共享性。 智慧环境建设则侧重于基于物联网的设备管理,通过智慧教室管理系统实现教室环境的智能控制和能效管理,打造绿色、节能的校园环境。电子班牌和校园信息发布系统的建设,将作为智慧校园的核心和入口,提供教务、一卡通、图书馆等系统的集成信息。 总体而言,智慧校园整体解决方案通过集成先进技术,不仅提升了校园的信息化水平,而且优化了教学和管理流程,为学生、教师和家长提供了更加便捷、个性化的教育体验。
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值