本题要求实现函数,可以返回一个给定月份的英文名称。
函数接口定义:char *getmonth( int n );
函数getmonth应返回存储了n对应的月份英文名称的字符串头指针。如果传入的参数n不是一个代表月份的数字,则返回空指针NULL。
输入样例1:
5
输出样例1:
May
输入样例2:
15
输出样例2:
wrong input!
裁判测试程序样例:
#include <stdio.h>
char *getmonth( int n );
int main()
{
int n;
char *s;
scanf("%d", &n);
s = getmonth(n);
if ( s==NULL ) printf("wrong input!\n");
else printf("%s\n", s);
return 0;
}
/* 你的代码将被嵌在这里 */
char *getmonth( int n )
{
char *e[13]={"January","February","March","April","May","June","July","August","September","October","November","December"};
if(n>=1&&n<=12)
return e[n-1];
else
return NULL;
}