试题 算法提高 八数码
资源限制
时间限制:1.0s 内存限制:256.0MB
问题描述
RXY八数码,给出初始状态和目标状态,通过移动数字0(可上、下、左、右方向移动一格)使初始状态变为目标状态,求最少移动多少步?
输入格式
输入两个3*3表格
第一个为目标表格
第二个为检索表格
输出格式
输出最少移动步数
样例输入
1 2 3
4 5 6
7 8 0
1 2 3
4 5 6
7 0 8
样例输出
1
数据规模与约定
3*3*2
试题解析
该题为最短路的问题所以采用 广度优先搜索(BFS) 更好一些
思路:
- 移动数字0,使达到目标状态,0每次有四种选择,但因为要使用BFS需要存储每一步后的状态,若用二维数组显然不太合适,所以我们把3×3的网格转化成长为9的字符串,这样在队列中存储更加方便,起初记录初始状态和目标状态,其中代码部分的哈希表d表示到达某状态需要移动多少次
- 开始搜索,取出队头若当前状态为目标状态之间返回步数,记录当前所需步数,及找到0的下标并将其转化成网格中的坐标遍历其可移动的四个方向,移动到新的位置等价于交换两个字符的位置,若当前状态没有出现过则记录入队,然后回溯
代码
注:以下代码为c++11版本之后支持的写法,蓝桥杯的评测机目前是c++98
需要把代码中的unordered_map改为map,把auto改为string
#include <cstdio>
#include <queue>
#include <string>
#include <unordered_map>
using namespace std;
int dx[] = {-1, 1, 0, 0}, dy[] = {0, 0, -1, 1};
bool in(int x, int y) {
return x < 0 || x >= 3 || y < 0 || y >= 3;
}
int bfs(string start, string end) {
queue<string> q;
unordered_map<string, int> d;
q.push(start);
d[start] = 0;
while (q.size()) {
auto t = q.front();
q.pop();
if (t == end) return d[t];
int dis = d[t], k = t.find('0');
int x = k / 3, y = k % 3;
for (int i = 0; i < 4; ++ i) {
int nx = x + dx[i], ny = y + dy[i];
if (in(nx, ny)) continue;
swap(t[k], t[nx * 3 + ny]);
if (!d.count(t)) {
d[t] = dis + 1;
q.push(t);
}
swap(t[k], t[nx * 3 + ny]);
}
}
return -1;
}
int main() {
string start, end;
for (int i = 0; i < 18; ++ i) {
char num[2];
scanf("%s", num);
if (i < 9) start += num;
else end += num;
}
printf("%d", bfs(start, end));
return 0;
}