poj_3126 Prime Path

先建素數表。一個數字要改變某位上的數時就轉成字符數組,傳遞參數時再轉成整型。用bfs搜。

 

3126Accepted712K32MSG++1689B2014-07-16 00:30:11

Prime Path
Time Limit: 1000MS Memory Limit: 65536K
Total Submissions: 10968 Accepted: 6236

Description

The ministers of the cabinet were quite upset by the message from the Chief of Security stating that they would all have to change the four-digit room numbers on their offices.
— It is a matter of security to change such things every now and then, to keep the enemy in the dark.
— But look, I have chosen my number 1033 for good reasons. I am the Prime minister, you know!
— I know, so therefore your new number 8179 is also a prime. You will just have to paste four new digits over the four old ones on your office door.
— No, it’s not that simple. Suppose that I change the first digit to an 8, then the number will read 8033 which is not a prime!
— I see, being the prime minister you cannot stand having a non-prime number on your door even for a few seconds.
— Correct! So I must invent a scheme for going from 1033 to 8179 by a path of prime numbers where only one digit is changed from one prime to the next prime.

Now, the minister of finance, who had been eavesdropping, intervened.
— No unnecessary expenditure, please! I happen to know that the price of a digit is one pound.
— Hmm, in that case I need a computer program to minimize the cost. You don't know some very cheap software gurus, do you?
— In fact, I do. You see, there is this programming contest going on... Help the prime minister to find the cheapest prime path between any two given four-digit primes! The first digit must be nonzero, of course. Here is a solution in the case above.
1033
1733
3733
3739
3779
8779
8179
The cost of this solution is 6 pounds. Note that the digit 1 which got pasted over in step 2 can not be reused in the last step – a new 1 must be purchased.

Input

One line with a positive number: the number of test cases (at most 100). Then for each test case, one line with two numbers separated by a blank. Both numbers are four-digit primes (without leading zeros).

Output

One line for each case, either with a number stating the minimal cost or containing the word Impossible.

Sample Input

3
1033 8179
1373 8017
1033 1033

Sample Output

6
7
0

Source

 
代碼:
 
#include<cstdio>
#include<cstdlib>
#include<cstring>
#include<queue>
using namespace std;
int p[10000],visit[10000],deep[10000];
void gen_prime()
{
   int i,j;
   p[1]=1;
   for(i=2;i<=5000;i++)
   {
      j=2;
      while(1)
      {
         int k=i*j;
         if(k>10000) break;
         p[k]=1;
         j++;
      }
   }
}
int bfs(int x,int y)
{
   queue<int>q;
   char c[5];
   int i,j;
//   memset(c,'\0',sizeof(c));
//   sprintf(c,"%d",x);
   if(x==y) return 0;
   q.push(x);
   visit[x]=1;
   while(!q.empty())
   {
//      printf("en\n");
    int h=q.front();
    memset(c,'\0',sizeof(c));
    sprintf(c,"%d",h);
//    printf("d=%s h=%d\n",c,h);
    q.pop();
    for(i=0;i<10;i++)
      {
         for(j=0;j<4;j++)
         {
         if(!(i==0 && j==0))
            {
             char tmp[5];
             memset(tmp,'\0',sizeof(tmp));
             strcpy(tmp,c);

             tmp[j]=i+'0';
             int k=atoi(tmp);
//             printf("str=%s k=%d\n",tmp,k);
             if(!p[k] && !visit[k])
             {
               visit[k]=1;
               q.push(k);
               deep[k]=deep[h]+1;
               if(k==y) return deep[k];
             }
            }
         }
      }
   }
   return -1;
}
int main()
{
   freopen("in.txt","r",stdin);
   int n,m,i,j;
   memset(p,0,sizeof(p));
   gen_prime();
   scanf("%d",&n);
   while(n--)
   {
      int x,y;
      scanf("%d%d",&x,&y);
      char c[5];
      memset(c,'\0',sizeof(c));
      memset(visit,0,sizeof(visit));
      memset(deep,0,sizeof(deep));
      int ans=bfs(x,y);
      printf("%d\n",ans);
   }
   return 0;
}

 
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值