set

Andy, 8, has a dream - he wants to produce his very own dictionary. This is not an easy task for him, as the number of words that he knows is, well, not quite enough. Instead of thinking up all the words himself, he has a briliant idea. From his bookshelf he would pick one of his favourite story books, from which he would copy out all the distinct words. By arranging the words in alphabetical order, he is done! Of course, it is a really time-consuming job, and this is where a computer program is helpful. You are asked to write a program that lists all the different words in the input text. In this problem, a word is defined as a consecutive se- quence of alphabets, in upper and/or lower case. Words with only one letter are also to be considered. Furthermore, your program must be CaSe In- SeNsItIvE. For example, words like “Apple”, “apple” or “APPLE” must be considered the same. Input The input file is a text with no more than 5000 lines. An input line has at most 200 characters. Input is terminated by EOF. Output Your output should give a list of different words that appears in the input text, one in a line. The words should all be in lower case, sorted in alphabetical order. You can be sure that he number of distinct words in the text does not exceed 5000.

Sample Input

Adventures in Disneyland Two blondes were going to Disneyland when they came to a fork in the road.

The sign read: "Disneyland Left."

So they went home.

Sample Output

a

adventures

blondes

came

disneyland

fork

going

home

in

left

read

road

sign

so

the

they

to

two

went

were

when

#include<iostream>
#include<set>
#include<cstring>
#include<string>
using namespace std;
string ss; 
int main()
{  int i=0;
string s;
set<string>sss;

   while(getline(cin,s))
   {  
       s+=',';
   	   for(int i=0;i<s.length();i++)
   	   {
   	   	if(isalpha(s[i]))
   	   	{  
			   char q=tolower(s[i]);
   	   	   ss+=q;
   	   		
		  }
		  
		  else{ 
		  sss.insert(ss);
		  ss.clear();
		
		 } 
		  
		  
	}
	} 
     set<string>::iterator it;//定义前向迭代器
     for(it=sss.begin();it!=sss.end();it++){
         if(*it!="")
		 cout<<*it<<endl; 
         
     } 
	
	
	return 0;
}

使用set可以让字符串按照字典从小到大排序

sss就是要放到set里面的字符串

ss是保存暂时的字符串

每次使用都要清空

评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值