PAT A 1077. Kuchiguse (20)

题目

The Japanese language is notorious for its sentence ending particles. Personal preference of such particles can be considered as a reflection of the speaker's personality. Such a preference is called "Kuchiguse" and is often exaggerated artistically in Anime and Manga. For example, the artificial sentence ending particle "nyan~" is often used as a stereotype for characters with a cat-like personality:

  • Itai nyan~ (It hurts, nyan~)
  • Ninjin wa iyada nyan~ (I hate carrots, nyan~)

    Now given a few lines spoken by the same character, can you find her Kuchiguse?

    Input Specification:

    Each input file contains one test case.  For each case, the first line is an integer N (2<=N<=100). Following are N file lines of 0~256 (inclusive) characters in length, each representing a character's spoken line. The spoken lines are case sensitive.

    Output Specification:

    For each test case, print in one line the kuchiguse of the character, i.e., the longest common suffix of all N lines. If there is no such suffix, write "nai".

    Sample Input 1:

    3
    Itai nyan~
    Ninjin wa iyadanyan~
    uhhh nyan~
    

    Sample Output 1:

    nyan~
    

    Sample Input 2:

    3
    Itai!
    Ninjinnwaiyada T_T
    T_T
    

    Sample Output 2:

    nai
    

     

    即求串尾的最长公用子串,暂存,从后面向前扫即可。

     

    代码:

    #include <iostream>
    #include <string>
    using namespace std;
    
    int main()
    {
    	int n;
    	cin>>n;
    	cin.get();
    
    	int i,j;
    	string *sdata=new string [n];	//存储所用字符串
    	int min_size=256;	//记录最小的字符串
    	for(i=0;i<n;i++)
    	{
    		getline(cin,sdata[i]);
    		if(sdata[i].size()<min_size)
    			min_size=sdata[i].size();
    	}
    
    	string common;
    	char ctemp;
    	for(i=0;i<min_size;i++)	//从尾开始扫
    	{
    		ctemp=sdata[0][sdata[0].size()-i-1];
    		for(j=1;j<n;j++)
    		{
    			if(sdata[j][sdata[j].size()-i-1]!=ctemp)
    				break;
    		}
    		if(j>=n)
    			common+=ctemp;
    		else
    			break;
    	}
    
    	if(common.size()==0)	//输出
    		cout<<"nai";
    	else
    	{
    		for(i=common.size()-1;i>=0;i--)
    			cout<<common[i];
    	}
    
    	delete [] sdata;
    
    	return 0;
    }
    


     

     

     

     

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值