PAT A 1085. Perfect Sequence (25)

题目

Given a sequence of positive integers and another positive integer p.  The sequence is said to be a "perfect sequence" if M <= m * p where M and m are the maximum and minimum numbers in the sequence, respectively.

Now given a sequence and a parameter p, you are supposed to find from the sequence as many numbers as possible to form a perfect subsequence.

Input Specification:

Each input file contains one test case.  For each case, the first line contains two positive integers N and p, where N (<= 105) is the number of integers in the sequence, and p (<= 109) is the parameter.  In the second line there are N positive integers, each is no greater than 109.

Output Specification:

For each test case, print in one line the maximum number of integers that can be chosen to form a perfect subsequence.

Sample Input:

10 8
2 3 20 4 5 1 6 7 8 9

Sample Output:

8

 

n*log(n)的方法:

1、排序;

2、记录序列的头、尾,向后扫描:

  2.1、如果尾小于等于头的p倍,尾向后;

  2.2、否则,头向后;

 

代码:

#include <iostream>
#include <vector>
#include <algorithm>
using namespace std;

int main()
{
	int n,p,i=0;	//n,p
	long long templl;	//临时数据
	vector<long long> seq;	//序列
	cin>>n>>p;	//输入
	for(i=0;i<n;i++)
	{
		cin>>templl;
		seq.push_back(templl);
	}
	sort(seq.begin(),seq.end());	//排序
	int max=0,begin=0,end=0;	//最大的长度,当前范围的头,超尾
	while(end<n)	//从头到尾扫描
	{
		templl=seq[begin]*p;
		while(end<n&&seq[end]<=templl)
			end++;
		if(max<end-begin)
			max=end-begin;
		begin++;
	}
	cout<<max;	//输出结果

	return 0;
}


 

 

 

 

 

  • 0
    点赞
  • 0
    收藏
    觉得还不错? 一键收藏
  • 0
    评论
评论
添加红包

请填写红包祝福语或标题

红包个数最小为10个

红包金额最低5元

当前余额3.43前往充值 >
需支付:10.00
成就一亿技术人!
领取后你会自动成为博主和红包主的粉丝 规则
hope_wisdom
发出的红包
实付
使用余额支付
点击重新获取
扫码支付
钱包余额 0

抵扣说明:

1.余额是钱包充值的虚拟货币,按照1:1的比例进行支付金额的抵扣。
2.余额无法直接购买下载,可以购买VIP、付费专栏及课程。

余额充值